Opened 6 years ago

Closed 6 years ago

#7697 closed Bug (fixed)

CKEditor crashes on next .replace() command after SCAYT context menu initialization.

Reported by: WebSpellChecker.net Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.5.4
Component: UI : Spell Checker Version: 3.5.3
Keywords: Cc: support@…

Description

This problem can be reproduced on CKEditor 3.5.3 released compressed version only.

CKEditor crashes on .replace() command after SCAYT context menu shown and editor destroyed.

Steps to reproduce:

  1. Create instance of CKEditor.
  1. Switch SCAYT on.
  1. Type misspelled words.
  1. Open context menu on misspelling twice.
  1. Destroy instance using :
    CKEDITOR.instances['editor'].destroy();
    


  1. Create instance of CKEditor using :
     CKEDITOR.replace("editor");
    


Expected results: editor appears.

Actual results: the editor is not displayed due to a javascript error.

Attachments (1)

7697.patch (748 bytes) - added by WebSpellChecker.net 6 years ago.

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by WebSpellChecker.net

Attachment: 7697.patch added

comment:1 Changed 6 years ago by WebSpellChecker.net

Keywords: HasPatch Review? added

comment:2 Changed 6 years ago by Jakub Ś

Status: newconfirmed

This problem can be reproduced on released compressed version only.

Reproducible from CKEditor version 3.5.3

comment:3 Changed 6 years ago by Frederico Caldeira Knabben

Keywords: HasPatch Review? removed
Milestone: CKEditor 3.5.4
Owner: set to Frederico Caldeira Knabben
Status: confirmedreview

comment:4 Changed 6 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

comment:5 Changed 6 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: review_passedclosed

Fixed with [6876].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy