Opened 8 years ago

Closed 5 years ago

Last modified 5 years ago

#7743 closed Bug (fixed)

Chrome: Flash dialog preview does not display when the dialog is positioned over the editing area

Reported by: James Cunningham Owned by:
Priority: Normal Milestone:
Component: UI : Dialogs Version: 3.0
Keywords: IBM Chrome Cc: Damian, Satya Minnekanti, Teresa Monahan

Description

Steps to reproduce the defect:

  1. Open the Ajax sample in Chrome.
  1. Click into the editor & open the Flash Properties dialog.
  1. Insert the following URL into the URL field http://bytescout.com/files/demo/swfscout_VideoSample.swf
  1. Click into any of the other fields in the dialog.

Expected: A preview of the flash video can be seen in the preview field in the dialog.

Actual: Only part of the flash video can be seen in the preview field.

Note: The full flash preview can be seen if you drag the dialog so that the preview field is not over the editing area.

Attachments (1)

test.png (66.7 KB) - added by Jakub Ś 8 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 8 years ago by Jakub Ś

Status: newconfirmed
Version: 3.5.33.0

Has happened since version 3.0, but prior to version 3.5.1 you have to move the dialog to see the effect.

Changed 8 years ago by Jakub Ś

Attachment: test.png added

comment:2 Changed 8 years ago by Jakub Ś

If you insert am URL to image or flash in 'Flash Dialog' you will see that there is no preview or part of preview.

Now grab the dialog and start moving it. You will see that parts of preview that are out side editor's content area are visible (See test.png)

Test URL: http://a.cksource.com/c/1/inc/img/demo-little-red.jpg

comment:3 Changed 8 years ago by Jakub Ś

#8671 was marked as duplicate.

comment:4 Changed 8 years ago by marcoex

[removed]

Last edited 8 years ago by marcoex (previous) (diff)

comment:5 Changed 8 years ago by marcoex

Hi, I found the problem, when creating the flash preview (via javascript in CKEditor) he ends up behind the main editor iframe, this drawing shows the window that inserts the flash down. Even changing 'z-index' can not fix. Here in the company instead of printing the 'embed', create an 'iframe' pointing to a page that creates the 'embed', so it works in Chrome.

before: dialog.preview.setHtml( '<embed height="100%" width="100%" src="'

+ CKEDITOR.tools.htmlEncode( previewPreloader.getAttribute( 'src' ) ) + '" type="application/x-shockwave-flash"></embed>' );

after:

dialog.preview.setHtml('<iframe src="/app/include/ckeditor/plugins/flash/dialogs/preview.asp?src=' + src + '" style="width: 100%; height: 100%"> </iframe>');

comment:6 Changed 5 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

I'm not able to reproduce this issue on any CKEditor version so apparently it was fixed in the Flash plugin.

comment:7 Changed 5 years ago by Jakub Ś

I confirm that it is fixed. I wasn't able to reproduce it as well.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy