Opened 7 years ago

Closed 5 years ago

#7745 closed Bug (fixed)

Instructions on how to access help dialog should be placed in an aria-describedby attribute

Reported by: Satya Minnekanti Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.6.4
Component: Accessibility Version:
Keywords: IBM VendorFix Cc: Damian, James Cunningham, Teresa Monahan

Description

This needs to be changed because when we bring up the list of frames on a page using JAWS, it shows CK Editor but also the extra help statement that we kept in the title attribute.This will confuse the users & we don't need this when identifying frames, we use that statement only for JAWS users on how to find help dialog.

Best way to fix this is to keep the Help Instructions in an aria-describedby attribute instead of on the Title attribute for the content area.

Attachments (6)

7745_test.patch (1.3 KB) - added by Garry Yao 6 years ago.
editable_iframe_aria-describedby.html (343 bytes) - added by Garry Yao 6 years ago.
inspect32_result.png (68.5 KB) - added by Damian 6 years ago.
Example Inspect32 result for tc
7745_2.patch (4.1 KB) - added by Garry Yao 6 years ago.
path compensate description with aria live region
7745.patch (2.9 KB) - added by Garry Yao 6 years ago.
7745_3.patch (2.9 KB) - added by Frederico Caldeira Knabben 6 years ago.

Download all attachments as: .zip

Change History (27)

comment:1 Changed 7 years ago by Frederico Caldeira Knabben

Component: GeneralAccessibility
Status: newconfirmed

If I recall it well, we have put the description in the title because of browser compatibility issues. Having it there enlarged the accessibility support for the announcement instructions to more browsers.

We need to check whether changing it for Firefox is ok, making it a special case, still leaving the title thing there for other browsers.

comment:2 Changed 7 years ago by Garry Yao

Exactly as Fred explained, we cannot get aria label work for wysiwyg mode (on iframe) unless FS could give us some hints of it, this is hold for all browsers up till now.

comment:3 in reply to:  2 Changed 7 years ago by Damian

Replying to fredck:

We need to check whether changing it for Firefox is ok, making it a special case, still leaving the title thing there for other browsers.

We're not really looking for a browser specific fix in this case.

Replying to garry.yao:

Exactly as Fred explained, we cannot get aria label work for wysiwyg mode (on iframe) unless FS could give us some hints of it, this is hold for all browsers up till now.

Ok, I'll try to investigate how this is supposed to work with FS.

comment:4 Changed 7 years ago by Frederico Caldeira Knabben

Status: confirmedpending

comment:5 Changed 6 years ago by Damian

This has been addressed in JAWS 12.0.1167.

Frames should be able to have the aria-describedby attribute like any other component. JAWS now recognizes descriptions applied to Frames.

Last edited 6 years ago by Damian (previous) (diff)

comment:6 Changed 6 years ago by Frederico Caldeira Knabben

Status: pendingconfirmed

We need to check it with the latest JAWS at this point.

Changed 6 years ago by Garry Yao

Attachment: 7745_test.patch added

comment:7 Changed 6 years ago by Garry Yao

Keywords: VendorFix added

By applying the patch, at least IE will not announce anymore the editor instructions upon focused, so this hack has to be remained.

comment:8 Changed 6 years ago by Damian

The patch sets an aria-label on the iframe, but it should be setting aria-describedby instead.

We should still keep the title attribute on the iframe, then we won't need an aria-label.

comment:9 Changed 6 years ago by Damian

Why is this still marked as VendorFix? Could we remove it?

comment:10 in reply to:  8 ; Changed 6 years ago by Garry Yao

Replying to damo:

The patch sets an aria-label on the iframe, but it should be setting aria-describedby instead.

We should still keep the title attribute on the iframe, then we won't need an aria-label.

It's not working...please check the tc attached.

Changed 6 years ago by Garry Yao

comment:11 in reply to:  10 Changed 6 years ago by Damian

Replying to garry.yao:

It's not working...please check the tc attached.

I tried this with FF 10 and JAWS 13, when focusing on the IFrame it reads the description.

There is still one problem with the tc, it does not set a name for the IFrame. I propose that you put a title on the IFrame, as you have been doing up till now. So, then the aria-describedby attribute only contributes the "Press Alt 0 for help" text.

E.g.

<iframe title="Rich Text Editor, editor1" aria-describedby="id1" ...>
<span id="id1">Press Alt 0 for help</span>

Also, I have used Inspect32 to test that the description is properly being conveyed by the browser in your tc, see attached screen shot.

Changed 6 years ago by Damian

Attachment: inspect32_result.png added

Example Inspect32 result for tc

comment:12 Changed 6 years ago by Garry Yao

The problem is not FF, could you check it in IE with JAWS 13?

comment:13 Changed 6 years ago by Garry Yao

Owner: set to Garry Yao
Status: confirmedreview

The patch follows the standard way of describing the editable frame in ARIA, while still provide the fallback for JAWS to work properly with IE, so the JAWS announcement would be:

  • IE : Rich text editor, editor1, press alt 0 for help - edit
  • FF: Rich text editor - edit, editor1, press alt 0 for help

Changed 6 years ago by Garry Yao

Attachment: 7745_2.patch added

path compensate description with aria live region

comment:14 Changed 6 years ago by Garry Yao

Another new patch that takes the ARIA live region approach to announce the frame description, at least with JAWS13, the result is browser independent:

Rich text editor (label) - edit (role) - blah, blah (text line) - press alt 0 for help (description).

Changed 6 years ago by Garry Yao

Attachment: 7745.patch added

comment:15 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6.3

Changed 6 years ago by Frederico Caldeira Knabben

Attachment: 7745_3.patch added

comment:16 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6.3
Status: reviewassigned

I'm attaching a new patch for it, which makes the minimum changes to satisfy the ticket request.

The patch solves the problem with the frames list (INS+F9).

The following are result we're having with the browsers.

On IE 9:

Before patch: "Rich text editor, editor1, press ALT+0 for help, edit, {read contents}, type in text" (Good)

After patch: "Rich text editor, editor1, press ALT+0 for help, edit, {read contents}, type in text" (Good)

So, no changes at all.

On FF 11:

Before Patch: "Rich text editor, editor1, press ALT+0 for help, frame, edit, {read contents}, type in text"

After Patch: "Rich text editor, editor1, frame, press ALT+0 for help, edit, {read contents}, press ALT+0 for help, type in text"

Although we have the INS+F9 issue solved, you can see that we have problems with FF, which announces the description twice.


Considering that the patch brings the above issue, we should hold on with this patch until well be able to have Firefox and JAWS working well with it.

I think the focus behavior is more important than the Frames List issue and, sincerely speaking, I would instead try to find a way to not list the editor in the frames list at all, because it is senseless.

comment:17 Changed 6 years ago by Damian

The problem with JAWS announcing descriptions twice is a known JAWS defect, being addressed.

I think the focus behavior is more important than the Frames List issue and, sincerely speaking, I would instead try to find a way to not list the editor in the frames list at all, because it is senseless.

We're having some internal discussion about this one. There is some agreement about hiding the frame semantics for the editor.

comment:18 Changed 5 years ago by Damian

Considering that JAWS will fix the issue of reading the description twice, we should implement the current fix. It works in FF and IE.

comment:19 Changed 5 years ago by Frederico Caldeira Knabben

Owner: changed from Garry Yao to Frederico Caldeira Knabben
Status: assignedreview

comment:20 Changed 5 years ago by Garry Yao

Milestone: CKEditor 3.6.4
Status: reviewreview_passed

comment:21 Changed 5 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: review_passedclosed

Fixed with [7499].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy