Opened 12 years ago

Closed 8 years ago

#775 closed Bug (worksforme)

Adding table rows using tab-key doesn't preserve attributes

Reported by: shimberger@… Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5.1
Keywords: SF FireFox Cc:

Description

My System:

FireFox: 1.5 OS: Windows XP Prof. FCKEditor: 2.3.1

Description: If i edit a table similar to this:

<table>
<tr><td class="somestyle">Content</td></tr>
</table>

left click on the content cell and choose to insert a new table row the class-attribute of the newly created row will be similar to the one of the clicked row. If i instead press tab to insert a new table row the class-attribute is lost. Since i'm using this feature inside a cms to let the editors edit specially markuped tables it would be very useful if the behaviours could be unified.

Thanks very much for your work on this project!


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1560844&group_id=75348&atid=543653

Change History (4)

comment:1 Changed 12 years ago by Martin Kou

Reporter: changed from Martin Kou to shimberger@…

comment:2 Changed 12 years ago by Wojciech Olchawa

Keywords: Confirmed FF added

Confirmed in FF2.

In IE the problem is bigger - when pressing the TAB button the table is only highlighted and a new row isn't added at all. I've opened a new ticket for it. (see #1830)

comment:3 Changed 12 years ago by Wojciech Olchawa

Version: FCKeditor 2.5.1

comment:4 Changed 8 years ago by Krzysztof Studnik

Resolution: worksforme
Status: confirmedclosed

WFM in CKE3.6.1 under IE8
FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy