Opened 8 years ago

Closed 5 years ago

#7770 closed Bug (fixed)

JS errors when selecting noneditable text in FF4

Reported by: Jakub Ś Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: Firefox4 Cc:

Description

I have found this bug when testing #7694

  1. Open Ajax sample
  2. Copy the below code and paste it in source mode:
    <p>paragraph [one</p>
    <div contenteditable="false">none editable block</div>
    <p>paragraph] two</p>
    
  3. Switch to WYSIWYG mode
  4. Select whole "none editable block" text with a mouse and click on a size combo box. The JS error may be thrown
  5. If size combo is shown and no error is not thrown, than select size, click on font combo select a font, deselect the text by clicking on “paragraph] two”, select whole text again and click on size combo.
  6. If still can not reproduce it, try different combinations with selecting text, deselecting text, clicking on size combo, clicking on font combo. Sooner or later the error should be thrown.

The error is:

Location: _source/plugins/wysiwygarea/plugin.js Message: control.is is not a function

if ( control.is( 'img', 'hr', 'input', 'textarea', 'select' ) )

plugin.js (Line 653)

Message: ev.getTarget().is is not a function

if ( ev.getTarget().is( 'a' ) && ev.$.button != 2 )

plugin.js (Line 682)



I have managed to reproduce it only in FF4.

Change History (4)

comment:1 Changed 8 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 8 years ago by Garry Yao

Status: confirmedpending

WFM in FF4/Win7, can you figure out a stable procedure to reproduce?

comment:3 Changed 8 years ago by Jakub Ś

Status: pendingconfirmed
Version: 3.33.0

New TC which should be easier to reproduce:

  1. Open Ajax sample
  2. Copy the below code and paste it in source mode:
    <p>paragraph [one</p>
    <div contenteditable="false">none editable block</div>
    <p>paragraph] two</p>
    
  3. Switch to WYSIWYG mode
  4. Select whole "none editable block" text with a mouse and move the selection a little bit to the right (See nonedit.png).
  5. Click on size combobox. The JS Error is thrown.

The error is:
Location: _source/plugins/wysiwygarea/plugin.js Message: control.is is not a function

if ( control.is( 'img', 'hr', 'input', 'textarea', 'select' ) )

plugin.js (Line 653)

Message: ev.getTarget().is is not a function

if ( ev.getTarget().is( 'a' ) && ev.$.button != 2 )

plugin.js (Line 682)

I have managed to reproduce it only in FF4 from CKEditor 3.0.

comment:4 Changed 5 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

Couldn't reproduce any of mentioned issues. We reworked a lot of related code in 4.3, so it was fixed on our side or on FF's side.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy