Opened 6 years ago

Closed 6 years ago

#7777 closed Bug (wontfix)

[FF4] Place cursor between text, apply any style: cursor drops

Reported by: MattMecham Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone:
Component: Core : Styles Version: 3.5.3
Keywords: Firefox Cc:

Description

To reproduce:

ckeditor.com/demo using Firefox 4. (Using FF 4.0.1 but reproducible in FF 4.0.0)

Type some text. For example "test".

Click anywhere in the text to place the cursor, for example after the "e".

Click on the font color menu and select a color, for example red.

The cursor drops down below the text and the cursor has the color selected.

Continue typing at the cursor returns as expected. Screenshot here: http://www.mattmecham.com/skitch/ckeditor-20110503-081933.jpg

Attachments (2)

7777.patch (843 bytes) - added by Frederico Caldeira Knabben 6 years ago.
collapsed_select_test.html (1.6 KB) - added by Frederico Caldeira Knabben 6 years ago.
Browser test page

Download all attachments as: .zip

Change History (6)

comment:1 Changed 6 years ago by Frederico Caldeira Knabben

Component: GeneralCore : Styles
Keywords: Firefox added; firefox color cursor removed
Status: newconfirmed
Summary: [FF4] Place cursor between text, select font color: cursor drops[FF4] Place cursor between text, apply any style: cursor drops

I can confirm it happens with *any* kind of style, even when applying bold. When you start typing, the style is properly applied. Seems to be a brand new FF4 bug. Works well with FF3.6.

To reproduce it, it's enough to place a collapsed selection at at part of the text, except at the end of paragraphs.

comment:2 Changed 6 years ago by Frederico Caldeira Knabben

Owner: set to Frederico Caldeira Knabben
Status: confirmedreview

FF4 felt down to the same level of FF2 in this ticket... it's enough to apply the same fix with have for it there.

Changed 6 years ago by Frederico Caldeira Knabben

Attachment: 7777.patch added

Changed 6 years ago by Frederico Caldeira Knabben

Attachment: collapsed_select_test.html added

Browser test page

comment:3 Changed 6 years ago by Frederico Caldeira Knabben

The attached TC page can be used to confirm the browser bug.

I've opened an issue for it at Mozilla:
https://bugzilla.mozilla.org/show_bug.cgi?id=654421

comment:4 Changed 6 years ago by Frederico Caldeira Knabben

Resolution: wontfix
Status: reviewclosed

This is already fixed on Firefox 5. Let's avoid adding browser specific hacks into our code.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy