Opened 12 years ago

Closed 12 years ago

#781 closed Bug (worksforme)

Justification not working

Reported by: atif123@… Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: SF Cc:

Description

Ok, I try to explain it once again.

unfortunately I cant tell you steps to create error but I can tell u scenario.Here it is.

I load a file from file system (Linux) called 'abc.html' containing 'ONLY AND ONLY' these codes

<div><strong>Atif</strong></div>

Now when I align the text 'center' and click on 'submit' button. The editor removes alignment from text and put it back to left justify before i save it back to the file. I mean

<div align="center"><strong>Atif</strong></div> BECOMES <div><strong>Atif</strong></div> AGAIN

It is not a matter whether it is surrounded by <div> (in case of firefox) or <p> in case of IE, it shows same behaviour. Yes but when I put <center> tag manually it works fine and does'nt remove <center> tag.

I dont understand because the very same editor works fine when I load html from DataBase but when I load it from file it creates problem.

//////////// The PHP Code getting html from file and
loading it to FCKeditor

$contents=file_get_contents("../htmlfiles/$ffilename");
<?php
$oFCKeditor = new FCKeditor
('pageBody') ;
$oFCKeditor->BasePath = 'FCKeditor/';
$oFCKeditor->Value = $contents;
$oFCKeditor->Height = '400' ;
$oFCKeditor->Create() ;
?>
///////////

Please Help!!

Thank you


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1569695&group_id=75348&atid=543653

Attachments (1)

EditPage.php (8.5 KB) - added by Martin Kou 12 years ago.
The file that is loading file to FCKeditor from both DataBase and File is attached. Moved from SF. Original author: atif123

Download all attachments as: .zip

Change History (3)

comment:1 Changed 12 years ago by Martin Kou

Reporter: changed from Martin Kou to atif123@…

Changed 12 years ago by Martin Kou

Attachment: EditPage.php added

The file that is loading file to FCKeditor from both DataBase and File is attached. Moved from SF. Original author: atif123

comment:2 Changed 12 years ago by Frederico Caldeira Knabben

Resolution: worksforme
Status: newclosed

I'm not able to reproduce it in any way with our nightly build.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy