Opened 10 years ago

Closed 10 years ago

#7815 closed Bug (fixed)

FF: Anchor icon is not visible in WYSIWYG

Reported by: Jakub Ś Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.6
Component: General Version: 3.6
Keywords: Firefox Cc:

Description

If you create an anchor in Firefox it's icon is not visible in WYSIWYG mode. Instead you see only collapsed blue dotted border.

If after creation you press enter and type a letter the icon shows up with this letter inside blue border.

Attachments (3)

anchor.png (23.2 KB) - added by Jakub Ś 10 years ago.
7815.patch (387 bytes) - added by Sa'ar Zac Elias 10 years ago.
7815_2.patch (750 bytes) - added by Frederico Caldeira Knabben 10 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 10 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 10 years ago by Wiktor Walc

Milestone: CKEditor 3.6

Changed 10 years ago by Jakub Ś

Attachment: anchor.png added

comment:3 Changed 10 years ago by Sa'ar Zac Elias

Owner: set to Sa'ar Zac Elias
Status: confirmedreview

Changed 10 years ago by Sa'ar Zac Elias

Attachment: 7815.patch added

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Status: reviewreview_failed

This fix will interfere on the height of the anchor when the text line is higher than 15px.

This is an issue caused by [6862]. I'm coming with a patch for it.

Changed 10 years ago by Frederico Caldeira Knabben

Attachment: 7815_2.patch added

comment:5 Changed 10 years ago by Frederico Caldeira Knabben

Owner: changed from Sa'ar Zac Elias to Frederico Caldeira Knabben
Status: review_failedreview

comment:6 Changed 10 years ago by Jakub Ś

I think that #7812 reported by Garry, describes very similar or the same issue

comment:7 Changed 10 years ago by Frederico Caldeira Knabben

#7812 has nothing to do with this. It's talking about having the <a> element split into several <a> elements. Here we're talking about a rendering issue that makes empty anchors not visible.

comment:8 Changed 10 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

comment:9 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: review_passedclosed

Fixed with [6875].

Note: See TracTickets for help on using tickets.
© 2003 – 2020 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy