Opened 9 years ago

Closed 9 years ago

#7880 closed Bug (invalid)

Focus going back to Editor body when we activate dialogs from Context menu

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone:
Component: Accessibility Version:
Keywords: IBM Cc: Damian, James Cunningham, Teresa Monahan

Description

To reproduce the defect:

  1. with config option dialog_startupFocusTab : true insert a Table
  1. Using keyboard activate context menu on the Table and click on Table Properties option.

Expected Result: Table Properties dialog comes up and focus is on Table Properties tab.

Actual Result: Table Properties dialog comes up but focus is in Editor body.

Same issue happens with Flash or Image or Link

Change History (3)

comment:1 Changed 9 years ago by Jakub Ś

Status: newpending
  1. I have set in config.js config.dialog_startupFocusTab = true;
  2. Inserted table (using keyboard and mouse)
  3. Pressed Shift+F10
  4. Pressed Tab/Enter - the focus was on dialog as it suppose to.

I could not reproduce the issue neither on latest stable version nor on trunk. On which OS, browser does the issue occur?

comment:2 in reply to:  1 Changed 9 years ago by Satya Minnekanti

Replying to j.swiderski:

  1. I have set in config.js config.dialog_startupFocusTab = true;
  2. Inserted table (using keyboard and mouse)
  3. Pressed Shift+F10
  4. Pressed Tab/Enter - the focus was on dialog as it suppose to.

I could not reproduce the issue neither on latest stable version nor on trunk. On which OS, browser does the issue occur?

This issue not reproducible on nightly build now. some other fix might have solved this issue. Please close this ticket.

comment:3 Changed 9 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy