Opened 9 years ago

Closed 9 years ago

#7899 closed Bug (invalid)

window.opener.CKEDITOR.tools.callFunction not working in CKEditor 3.6

Reported by: bart-rcs Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6
Keywords: Cc:

Description

Today I was updating CKEditor from 3.5 to 3.6 and I noticed that the window.opener.CKEDITOR.tools.callFunction is not working anymore.

In 3.5 I used the following code without problems:

window.opener.CKEDITOR.tools.callFunction( funcNum, fileUrl, function() {
    // Get the reference to a dialog window.
    var element, dialog = this.getDialog();
    // Check if this is the Image dialog window.
    if (dialog.getName() == 'link') {
        // Get the reference to a text field that holds the "title" attribute.
        element = dialog.getContentElement( 'advanced', 'advTitle' );
        if (element) {
            element.setValue( trimTitle($('f_title').value) );
        }
    }
});

In 3.6 the above code is not working anymore. When I switch back to 3.5 it's working again.

Change History (4)

comment:1 Changed 9 years ago by Jakub Ś

Status: newpending

I’m afraid that function taken out of its context is not enough to recreate the issue. Could I ask you for sample HTML page (simplified Test Case) that exactly what the problem is.

comment:2 Changed 9 years ago by bart-rcs

I've taken the code directly from the documentation page so I hope that is enough context? See example 4 on the following page: http://docs.cksource.com/CKEditor_3.x/Developers_Guide/File_Browser_(Uploader)/Custom_File_Browser

That code listed there was working without problems on 3.5. However on 3.6 the same code is not working anymore

comment:3 Changed 9 years ago by Wiktor Walc

Note that in the link that you have mentioned, CKEditorFuncNum is extracted from the url, as shown for example in Example 2.

If you have hardcoded value of funcNum and always used "2" for example, then indeed things could stop working and in fact probably did never work right when there was more than one instance of CKEditor on the same page.

comment:4 Changed 9 years ago by bart-rcs

Resolution: invalid
Status: pendingclosed

My bad, I had indeed hardcoded the funcNum, because in the application I was using the CKEditorFuncNum was removed when changing the form.

So this is no bug in CKEditor 3.6. Thanks for your help!

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy