Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7901 closed Bug (invalid)

Images can be inserted as Flash objects

Reported by: James Cunningham Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.1
Keywords: IBM Cc: Damian, Teresa Monahan, Satya Minnekanti

Description

Steps to reproduce the defect:

  1. Open the Ajax sample.
  1. Open the flash dialog.
  1. Insert the following image URL into the URL field http://a.cksource.com/e/1/img/logo-ckeditor-h100.png & click OK. See that a flash placeholder is inserted into the editor.
  1. Remove the editor.

Result: The image is displayed although it is a flash object.

Change History (2)

comment:1 Changed 8 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

Flash place holder is displayed in editor only.

When you remove the editor the flash content is saved in the document. It may look like an image but it's an image inside flash object what can be easily checked with Firebug.

comment:2 Changed 8 years ago by Wiktor Walc

I believe that the ticket is more about being able to pass an URL to any file in the Flash dialog (text files, images etc.) and that no kind of URL validation is performed.

In any case I guess it can be left as invalid. Some users may want to paste an URL that points to a .php file that serves some random flash object, so restricting the URL field only to flash extensions might be too strict.

Since it's possible to specify custom validation rules using JavaScript API, I'd leave it as it is now.

Eventually, the other possible option would be to ask user for a confirmation whether the URL to a file is really valid (just like when pressing Cancel button), if the extension does not match some pattern.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy