Opened 10 years ago

Closed 10 years ago

#7904 closed Bug (fixed)

IE: We can't apply text/background color with out focus in editor body.

Reported by: Satya Minnekanti Owned by: Sa'ar Zac Elias
Priority: Normal Milestone: CKEditor 3.6.1
Component: General Version: 3.6.1
Keywords: IBM Cc: Damian, James Cunningham, Teresa Monahan

Description

To reproduce the defect:

Open Ajax sample, with out focus in Editor body click on text or background color drop down menu and select a color.

Expected Result: cursor goes to editor body and the selected text/background color applies to the empty paragraph.

Actual Result: we are getting an error and the error is "null is null or not an object". Cursor goes out of editor body and when we keep cursor in editor body using mouse and type the text the selected text/background color is not applied to the typed text.

Tested in IE6, IE7, IE8 & IE9

Attachments (4)

7904.patch (1.6 KB) - added by Sa'ar Zac Elias 10 years ago.
7904_2.patch (674 bytes) - added by Garry Yao 10 years ago.
7904_3.patch (1.8 KB) - added by Garry Yao 10 years ago.
7904_4.patch (2.2 KB) - added by Sa'ar Zac Elias 10 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 10 years ago by Jakub Ś

Status: newconfirmed

The JS error:
Message: 'null' is empty or not an object
Line: 1514
Char: 4
URI: /_source/plugins/styles/plugin.js

Just like in #7905 I've been able to confirm it only for IE8 and IE9 from rev [6920]

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6.1

It looks like we need to review something after [6920].

Changed 10 years ago by Sa'ar Zac Elias

Attachment: 7904.patch added

comment:3 Changed 10 years ago by Sa'ar Zac Elias

Owner: set to Sa'ar Zac Elias
Status: confirmedreview

Patch fixes also #7905 and #7919.

comment:4 Changed 10 years ago by Garry Yao

Status: reviewreview_failed

With the patch if previous focus is from another editor instance, focus is absorbed into the current one, which will break things like shared toolbar.

Changed 10 years ago by Garry Yao

Attachment: 7904_2.patch added

comment:5 Changed 10 years ago by Garry Yao

Other browsers are free of this trouble as the confirm click blurs the float panel properly.

comment:6 Changed 10 years ago by Sa'ar Zac Elias

Status: review_failedreview

Changed 10 years ago by Garry Yao

Attachment: 7904_3.patch added

comment:7 Changed 10 years ago by Garry Yao

Have to update the patch due to #7916, which is quite hard to get fixed with the same way in second patch.

comment:8 Changed 10 years ago by Sa'ar Zac Elias

Status: reviewreview_failed

With 7904_3 this ticket's TC fails while #7905, #7919 and #7916 are resolved.

Changed 10 years ago by Sa'ar Zac Elias

Attachment: 7904_4.patch added

comment:9 Changed 10 years ago by Sa'ar Zac Elias

Status: review_failedreview

comment:10 Changed 10 years ago by Garry Yao

Status: reviewreview_passed

comment:11 Changed 10 years ago by Sa'ar Zac Elias

Resolution: fixed
Status: review_passedclosed

Fixed with [6985].

Note: See TracTickets for help on using tickets.
© 2003 – 2020 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy