Opened 8 years ago

Closed 5 years ago

#7956 closed Bug (duplicate)

[[IE & Opera]] issues with PageUp & PageDown when Auto grow plugin(with it's default configuration) is loaded

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone:
Component: General Version: 3.4
Keywords: IBM Cc: Damian, James Cunningham, Teresa Monahan

Description

To reproduce the defect:

  1. UseAutoGrow(with it's default configuration) sample and enter content that spans multiple pages.
  1. Press PageUp button.

Expected Result: Cursor in editor body moves one page up.

Actual Result: Cursor goes to start of page content.

  1. Press PageDown button.

Expected Result: Cursor in editor body moves one page down.

Actual Result: Cursor goes to end of page content.

Tested against IE6, IE7, IE8, IE9 & Opera 11.11

Change History (3)

comment:1 Changed 8 years ago by Jakub Ś

Status: newconfirmed
Version: 3.4

At first I wanted to merge this one with #7955 as it touches the autogrow and pageUp problem. On second though these tickets concern different browser behavior so maybe it is best to treat them separately.

Below is the comment from #7955:

IE8, IE9 and Opera - with autoGrow_maxHeight set, there are no "pages", pressing page up moves cursor to the beginning of the text (no big deal). With default configuration pressing page-up moves the cursor to the beginning of the text but the browser doesn't scroll (Something like the first part of my comment in ticket #7946).

IE7 - with autoGrow_maxHeight set, only the browser is scrolled. Default configuration works here.

IE6 - with autoGrow_maxHeight set, scrolling works fine. With default configuration pressing page-up moves the cursor to the beginning of the text but the browser doesn't scroll just like IE9, IE8 and Opera.

Last edited 5 years ago by Piotrek Koszuliński (previous) (diff)

comment:2 Changed 8 years ago by Satya Minnekanti

we will get the same error even when we set maxHeight to large vale(for ex: 5000px) and when there are no scroll bars for the entered content

comment:3 Changed 5 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

IE6-7 and Opera 11 are no longer supported what makes this ticket a duplicate of #8382.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy