Opened 12 years ago

Closed 11 years ago

#796 closed Bug (invalid)

Toolbar is not visible

Reported by: anonymous Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: SF Cc: raj_aithal@…, Frederico Caldeira Knabben, blueboxsw@…, Alfonso Martínez de Lizarrondo

Description

On FCKEditor Toolbar click on source and then click on FitWindow icon, the editor is resized to maximum screenwidth and at the same time toolbar is missing. Now i can not minimize the editor

I have implemented FCKEditor Javascript API on aspx Page.

Code is given below

In fckconfig.js file

FCKConfig.ToolbarSets["MyFCKToolBar"] = [
['Source','Preview','-','Bold','Italic','Underline','TextColor','BGColor',
'-'],
['Cut','Copy','Paste','PasteText','PasteWord','-'],
['Undo','Redo','Find','Replace','SelectAll','-'],
['JustifyLeft','JustifyCenter','JustifyRight','JustifyFull','-'],
['OrderedList','UnorderedList','Outdent','Indent','-'],
['Table','Link','Unlink','SpecialChar','FitWindow']

in aspx page

var oFCKeditor = null;
function loadFCKEditor()
{

if(oFCKeditor == null)
{
debugger;
oFCKeditor = new FCKeditor( "<%=m_webHTMLEditor.ClientID%>" ) ;
oFCKeditor.ToolbarSet = "MyFCKToolBar";
oFCKeditor.BasePath = "./../FCKeditor/" ;
oFCKeditor.ReplaceTextarea() ;
}

}
/// the below event fires immideatly after the FCKEditor loading.
function FCKeditor_OnComplete( editorInstance )
{
//attached onblur event...
oFCKeditor.Events.AttachEvent( "OnBlur", OnBlurFCKEditor) ;

}

Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1615333&group_id=75348&atid=543653

Change History (2)

comment:1 Changed 12 years ago by Martin Kou

Cc: raj_aithal@… Frederico Caldeira Knabben blueboxsw@… Alfonso Martínez de Lizarrondo added
Reporter: changed from Martin Kou to anonymous

Hi blueboxsw

Just check for the DocType being the first line in the page. since am using the Frame it works fine, however if i dont have the doctype as first line it gives me the same issues. But based on alfonsoml comments and i moved the doctype as first line, then everything is working fine.

Last but not the least,Thanks for the help provided by the FCKEditor Team


Moved from SF. Original poster: raj_aithal

blueboxsw, are you able to produce a simple test case page that shows us the problem?


Moved from SF. Original poster: fredck

I have this problem as well. The editor is on a page within a frameset. When I click expand full screen, it fills the frame (which is good), but there are no scroll bars for either the WYSIWYG mode or the SOURCE mode, no matter how much information I add.

If I use the demo on the FCKeditor site, I can not reproduce the problem using the same steps.

Therefore, I'm guessing it has something to do with being in a frame...


Moved from SF. Original poster: blueboxsw

I've tried to change one of the sample files and it doesn't fail to me. Could you please create a minimum testcase with all the code that can show the problem?


Moved from SF. Original poster: alfonsoml

The DOCTYPE must be the first line of your page, putting it at any other place is the same that not adding it: your page isn't valid according to the standards and the browser can do any strange thing.


Moved from SF. Original poster: alfonsoml

This is happening only when i placed the doctype after html tag.

like...

<html xmlns="http://www.w3.org/1999/xhtml" >
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

If i placed the DOCTYPE in the first line it works fine. but in my application i have to place the doctype below the HTML tag.

Please let me know if any alternative except keeping the DOCTYPE as the first line.

Regards, Raj


Moved from SF. Original poster: raj_aithal

It works pretty well for me.

It is much probably something related to the page where the editor is placed in. I would ask you to please attach a test case page to this report, so we can reproduce the problem here, otherwise a fix for it is quite inviable.

Thanks again.


Moved from SF. Original poster: fredck

Please find the below requested details

Browser :- IE V6.0 + SP2 updated OS :- Windows XP Professional

onblur event

function OnBlurFCKEditor()
{
//    ...code to get the editor value and updating the datagrid cell
value
}

Moved from SF. Original poster: Anonymous

Can you give us some info about your browser and OS?

Also, what about the "OnBlurFCKEditor" function?


Moved from SF. Original poster: fredck

comment:2 Changed 11 years ago by Wojciech Olchawa

Resolution: invalid
Status: newclosed

Ticket expired.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy