Ticket #8042 (closed Bug: fixed)

Opened 3 years ago

Last modified 3 years ago

extra direction attribute after indentation

Reported by: garry.yao Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.6.1
Component: Core : BiDi Version: 3.6.1
Keywords: Cc:

Description

Load the following list:

<ol dir="rtl">
	<li>
		item1
		<ol dir="ltr">
			<li>
				item2</li>
		</ol>
	</li>
	<li>
		^item3</li>
</ol>
  1. Indent then outdent the 3rd item;
  • Actual Result: an unnecessary dir="rtl" created on the list item;
  • Expected Result: Content remains unchanged;

Attachments

8042.patch (964 bytes) - added by garry.yao 3 years ago.

Change History

comment:1 Changed 3 years ago by j.swiderski

  • Status changed from new to confirmed

Reproducible on all browsers from rev [6928].

comment:2 Changed 3 years ago by wwalc

  • Milestone set to CKEditor 3.6.1

Related issue (caused by the same changeset): #8053

Changed 3 years ago by garry.yao

comment:3 Changed 3 years ago by garry.yao

  • Owner set to garry.yao
  • Status changed from confirmed to review

comment:4 Changed 3 years ago by Saare

  • Status changed from review to review_passed

comment:5 Changed 3 years ago by garry.yao

  • Status changed from review_passed to closed
  • Resolution set to fixed

Fixed with [7054].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy