Opened 10 years ago

Closed 10 years ago

#8052 closed Bug (fixed)

Autogrow doesn't kick in on editor init

Reported by: Dinu Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.6.2
Component: General Version: 3.4 Beta
Keywords: NoTest Cc:

Description

To reproduce, use autogrow sample with the following content:

<table border="1" cellpadding="1" cellspacing="1" style="width: 100%; height: 1000px; ">
	<tbody>
		<tr>
			<td>
				 </td>
			<td>
				 </td>
		</tr>
		<tr>
			<td>
				 </td>
			<td>
				 </td>
		</tr>
		<tr>
			<td>
				 </td>
			<td>
				 </td>
		</tr>
	</tbody>
</table>
<p>
	 </p>

Second bug: in IE, click on first cell (to trigger autogrow) then click in the last paragraph after the table. Page will scroll. Third bug (I presume related, haven't thoroughly explored yet): in IE, adding a <div style="display:none"></div> at the end of the document triggers erratic resize and scrolling.

I have all these to be regressions against 3.5.4 with Gary's patch http://dev.ckeditor.com/ticket/7173

Attachments (2)

8052.patch (848 bytes) - added by Garry Yao 10 years ago.
8052_2.patch (537 bytes) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by Garry Yao

Status: newconfirmed

Auto grow is by design happened at the activation of an editor instance, the reason is that user might look for the initial (configured) editor size to fit in their page layout.

But we should allow those who'd like to see the grow happen upon editor creation, by invoking the "autogrow" command:

CKEDITOR.replace( 'editor1', {
	extraPlugins : 'autogrow',
	on : {
		'instanceReady' : function(ev)
		{
			ev.editor.execCommand( 'autogrow' );
		}
	}
});

Changed 10 years ago by Garry Yao

Attachment: 8052.patch added

comment:2 Changed 10 years ago by Garry Yao

Owner: set to Garry Yao
Status: confirmedreview
Version: 3.6.1 (SVN - trunk)3.4 Beta

comment:3 Changed 10 years ago by Garry Yao

For other bugs please open new tickets.

Changed 10 years ago by Garry Yao

Attachment: 8052_2.patch added

comment:4 Changed 10 years ago by Garry Yao

Command should not impose editor focus.

comment:5 Changed 10 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

comment:6 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6.2

comment:7 Changed 10 years ago by Garry Yao

Keywords: NoTest added
Resolution: fixed
Status: review_passedclosed

Fixed with [7203].

Note: See TracTickets for help on using tickets.
© 2003 – 2021 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy