Opened 8 years ago

Closed 8 years ago

#8153 closed New Feature (duplicate)

tab-key should increase indention of lists

Reported by: derstephan Owned by:
Priority: Normal Milestone:
Component: Core : Lists Version: 3.0
Keywords: Cc: vlq@…

Description

Would be nice, if pressing tab-key would move a list-item to the next sublevel, as it is done when pressing the "increase indent" button in toolbar.

And of course it would be good, if shift+tab would decrease indention.

Thanks in advance, Stephan

Change History (9)

comment:1 Changed 8 years ago by derstephan

Cc: vlq@… added
Version: 3.63.6.1

comment:2 Changed 8 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

Tab key is used for navigation on page.

comment:3 Changed 8 years ago by derstephan

Why is that? Tab key is not only used for navigation on the page but used in ckeditor e.g. for navigation within tables. So what is the use of leaving the editor with tab key in lists but not in tables?

And... the tab key is used for increasing indention of list-items in every word processor I know. So this is not a pointless suggestion.

Please reconsider your decision.

Regards,

Stephan

comment:4 Changed 8 years ago by Jakub Ś

Why is that? Tab key is not only used for navigation on the page but used in ckeditor e.g. for navigation within tables.

It's still navigation - you jump from one cell to the other just like on page where you jump from one element to the other.

And... the tab key is used for increasing indention of list-items in every word processor I know. So this is not a pointless suggestion.

I believe these are mainly offline editors you talk about. Of course there are also online editors which support such feature.

On one hand if someone is accustomed to navigating through page with tab key he will get angry when he indents list instead of getting out of editing area.On the other this is a cool feature which could simplify list indentation.

I’m really not sure here which is better.
I think it may be better to leave it the way it is.

comment:5 Changed 8 years ago by Jakub Ś

Resolution: invalid
Status: closedreopened

I have consulted this issue with others and it seems that I've got to quick when invalidating this ticket.

@derstephan thanks for pointing that out.

comment:6 Changed 8 years ago by Jakub Ś

Status: reopenedconfirmed
Version: 3.6.13.0

comment:7 in reply to:  4 Changed 8 years ago by derstephan

Replying to j.swiderski:

I’m really not sure here which is better.

I'd suggest to make this customizable. No harm done.

@derstephan thanks for pointing that out.

You are so welcome. Thanks for discussing and reconsidering it.

comment:8 Changed 8 years ago by klemens_u

+1 from my side. This is a MUST HAVE in my opinion. I'm currently upgrading a 2.x installation and it was easily possible in 2.x using the following config option:

FCKConfig.Keystrokes = [

  [ 09 /*TAB*/, 'Indent' ],
  [ SHIFT + 09 /*SHIFT+TAB*/, 'Outdent' ]
   
] ;

Sadly, this is not working in 3.x

See also this ticket: https://dev.ckeditor.com/ticket/8244

BTW: Another popular function is to set headlines using [CTRL]-[1,2,3m,] That doesn't seem to work as well

comment:9 Changed 8 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

@klemens_u, @derstephan I'm closing this ticket as a duplicate of #8244 as it contains proposition of a patch.

Please refer to #8244 in the future.

BTW: Another popular function is to set headlines using [CTRL]-[1,2,3m,] That doesn't seem to work as well

@klemens_u you can report this as a request feature (provided that it hasn't been already reported by some other user).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy