Opened 8 years ago

Closed 6 years ago

Last modified 6 years ago

#8170 closed New Feature (duplicate)

Mouse wheel

Reported by: Michal Malének Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

This is just a suggestion but it wouldn't hurt considering it: It would be nice, if mouse wheel used over the editor content disabled scrolling of the entire html page - in other words - if you scroll to the bottom (or top) of your ckeditor content, and keep scrolling (which you almost always do as it is hard to stop turning the wheel at the exact edge of the document), the entire page starts scrolling too, often moving the editor area out of view. It would be nice if there were a mouse wheel handler disabling scrolling of the entire page (but, of course, only if the mouse is over the edited content, elsewhere in the page, scrolling should move the entire page up and down - and leave the editor itself unaffected).

Change History (3)

comment:1 Changed 8 years ago by Jakub Ś

Status: newconfirmed

Sounds interesting.
IMO Besides scrolling also middle-click scroll should be disabled.
All should be enabled again when scroll in editor has reached the bottom.

Here is an example showing how can it be done in JavaScript : http://stackoverflow.com/questions/4770025/how-to-disable-scrolling-temporarily

and other useful JavaScripts:
http://stackoverflow.com/questions/3898130/how-to-check-if-a-user-has-scrolled-to-the-bottom
http://stackoverflow.com/questions/1930875/disabling-middle-click-scrolling-with-javascript

comment:2 Changed 6 years ago by Piotrek Koszuliński

There's a DUP in #10829, however, I kept it because it described a little bit different algorithm.

comment:3 Changed 6 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

@Michal Malének I closing this issue as duplicate of #10829. The later has a little bit more information.

Last edited 6 years ago by Jakub Ś (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy