Opened 12 years ago

Closed 11 years ago

#820 closed New Feature (fixed)

does not honour size widget argument

Reported by: madduck@… Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: SF Cc: macadames@…

Description

FCKeditor always renders in the same size. It would be nice if that size could be changed. The Archetypes RichtWidget class supports the 'size' argument for this purpose. Setting it to 20 should cause the widget to render with 20 lines shown. FCKeditor does not honour this setting, but it would be nice if it could be made to honour it.

Thanks,


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1214020&group_id=75348&atid=543656

Change History (3)

comment:1 Changed 12 years ago by Martin Kou

Type: BugNew Feature

comment:2 Changed 12 years ago by Martin Kou

Reporter: changed from Martin Kou to madduck@…

This Feature Request is for Plone and has been added in FCKeditor.Plone 2.0.2 package.

jean-mat


Moved from SF. Original poster: macadames

OK for your proposition

it works fine. Thank you


Moved from SF. Original poster: macadames

Thank you

I'll look at your patch and incorporate it , for the next release

;-)


Moved from SF. Original poster: macadames

Attached is a patch which implements my proposal.


Moved from SF. Original poster: madduck

I know widgets are easy to make. But I have two problems with it: (a) the RichWidget already has a size argument, so that should be used rather than just ignored, and (b) if I make a widget to support size changes for FCKeditor, maybe Kupu and Epoz won't work anymore, or then they will not honor the size change.

Point is: there is already an attribute for size and it should behave as expected. I should not need to implement this functionality again.


Moved from SF. Original poster: madduck

If you are able to play with Archetypes, i think you are able to create your own widgets, it's really easy you know.

In the 2.0 final release i will put a wysiwyg_support compatible with Archetypes RichText widget (it's not a good widget, but i will make it for specific development purpose), and compatible with Kupu and Epoz.

Very small feature easy to do, but i will do it especially for you. Big decision, ;-)


Moved from SF. Original poster: macadames

Perfect. Thanks.


Moved from SF. Original poster: madduck

It's not a fix, because it's not a bug, just a small feature request.

I will make FCKeditor wysiwyg_support compatible with this request in 2.0. OK ?

Best Regards

jean-mat


Moved from SF. Original poster: macadames

Okay, but it's somewhat of a shame that the default RichEdit widget's size argument cannot be used for this. I have about 60 users on the site, and half of them use Safari as the browser. Since FCKeditor does not (yet) support Safari, I installed Kupu for those guys. What you are telling me is to hardcode FCKeditor support into my site, aren't you?

I will look into making the size argument propagate to FCKeditor.

(resetting the resolution as I don't consider your proposal an acceptable fix.)


Moved from SF. Original poster: madduck

Your wrong you can do all the sizes you want and all widgets you want.

Take a look at the difference between : wywiwyg_support and mini_wysiwyg_support (a full size with all toolbars template and a small size with a small toolbar template)

With archetypes you can make your own wysiwyg widgets. As example you can call miniwysiwyg_support template in your wysiwyg_widget (archetype widget which call wysiwyg_support, you can change that), you can create all widgets you want with archetypes.

As example, go on http://macadames.com create your login + password go into your personal folder try "ajouter actualité" which means "add a new item" (sorry French language is forced)

You can see a small editor and a full editor ...

You need to read Archetypes doc and FCKeditor doc, you will find all you need.


Moved from SF. Original poster: macadames

comment:3 Changed 11 years ago by Alfonso Martínez de Lizarrondo

Resolution: fixed
Status: newclosed

according to

This Feature Request is for Plone and has been added in FCKeditor.Plone 2.0.2 package.

jean-mat

this has already been fixed.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy