Opened 8 years ago

Closed 8 years ago

#8202 closed Bug (duplicate)

[IE] Pasting or typing a textual link auto-hyperlinks it

Reported by: Brandon Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: IE Cc:

Description

We have noticed an odd browser inconsistency when integrating with CKEditor. The issue can be duplicated in the online demo here:

http://ckeditor.com/demo

Visit this page in IE8 or IE9 and scroll to the end of the editor area. Hit enter so you are on a new line. Type in (without quotes) "http://google.com" and then hit the space bar. Bug: The textual URL you just typed in is auto-hyperlinked.

Similarly, this bug exists when you paste in a textual link.

Open notepad/text editor and type in "http://google.com" without quotes. I am doing this just to ensure that we are not copying formatted data from some source. You can similarly copy the URL from the address bar. Go to an empty spot in the editor and hit ctrl + v to paste it in. Bug: The textual link you pasted in is auto-hyperlinked.

The issue is duplicated on Windows XP and Windows 7 (at least). The issue is not present in Firefox 5, Chrome 12, or Safari 5.

Attachments (1)

test.html (332 bytes) - added by Jakub Ś 8 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 8 years ago by Jakub Ś

Keywords: IE added
Status: newconfirmed
Version: 3.6.13.0

This feature is provided by a browser itself. Just open the attached file and type or paste http://google.com. You will see what I mean.
If you want to get rid of newly transformed link all you have to do is press BACKSPACE.

I'm confirming this ticked just in case if any of our senior developers think that it is a good idea to block this feature.

Changed 8 years ago by Jakub Ś

Attachment: test.html added

comment:2 Changed 8 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

I think I got to quick with this ticket.

This is let's say “reverse” DUP of #7376 which leads to a New Feature request #6307

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy