Opened 8 years ago

Closed 6 years ago

#8208 closed New Feature (duplicate)

Disable data URIs when pasting images

Reported by: Jeroen Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Firefox Cc:

Description

When pasting images into CKEditor in Firefox 5, a Data URI is used as image source. I would like to be able to disable this, so that in this case no image is pasted.

To reproduce:

  1. Right-click any image in Firefox 5
  2. Select 'Copy Image'
  3. Paste the image into CKEditor

Result:

The source of the pasted image is data:image/png;base64,iVBORw0KGgo...

This might be reproducible in other browsers as well.

I'm sorry, I don't know the right component for this ticket.

Thanks in advance.

Change History (5)

comment:1 Changed 7 years ago by Wiktor Walc

Keywords: Firefox added; image data uri copy paste disable removed
Status: newconfirmed

In Firefox local images are inserted as base64 encoded "inline" images:

<img alt="" src="data:image/jpeg;base64,/9j/4AAQSkZJRgAB...">
  • The problem is that IE6 doesn't recognize it and the user might not be aware of it.
  • It is rather inefficient, because such an image takes 140% of the size of an original image.
  • The URL field in the Image dialog displays raw data, it is definitely not user friendly.

comment:2 Changed 7 years ago by Alfonso Martínez de Lizarrondo

Just use this plugin: http://cksource.com/forums/viewtopic.php?f=18&t=23646 and all those problems are fixed.

comment:3 in reply to:  2 Changed 7 years ago by Jeroen

Replying to alfonsoml:

Just use this plugin: http://cksource.com/forums/viewtopic.php?f=18&t=23646 and all those problems are fixed.

Thanks, but I really don't want to save all pasted images on my server.

comment:4 Changed 7 years ago by Alfonso Martínez de Lizarrondo

Then modify the plugin to remove the pasted image instead of sending it to the server. Directly uploading by pasting is the hard part, not allowing to paste an image is quite easy.

comment:5 Changed 6 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

I believe this ticket can be closed as duplicate of #8021. This isn't a bug but how Firefox works. As it was mentioned in #8021 this can be either left, blocked in FF or implemented on other browsers.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy