Opened 8 years ago

Closed 6 years ago

#8258 closed Bug (fixed)

No undo after image/flash/iframe insertion on empty editor

Reported by: Frederico Caldeira Knabben Owned by:
Priority: Normal Milestone:
Component: Core : Undo & Redo Version: 3.3.2
Keywords: Firefox Opera Cc:

Description

  1. Load the Ajax sample.
  2. Create the editor.
  3. Without clicking in the editing area, click one of the image, flash or iframe buttons.
  4. Insert any URL in the dialog and confirm.
  5. Click the "Undo" button.

The inserted object is not removed. A second click on Undo removes it.

Confirmed with FF5 and Opera. Ok with IE9 and Safari.

Change History (7)

comment:1 Changed 8 years ago by Frederico Caldeira Knabben

comment:2 Changed 8 years ago by Jakub Ś

Status: newconfirmed
Version: 3.6.2 (SVN - trunk)3.3.2

I've been able to reproduce it in Opera , Firefox (3.6 - 5) from CKEditor 3.3.2 for images and flash. For iframes issue is reproducible from CKE 3.5 when they were introduced.

comment:3 Changed 8 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added

comment:4 Changed 8 years ago by Satya Minnekanti

Keywords: IBM added

comment:5 Changed 8 years ago by Satya Minnekanti

Keywords: IBM removed

comment:6 Changed 8 years ago by Satya Minnekanti

Cc: satya_minnekanti@… removed

comment:7 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

Not reproducible any more.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy