Opened 8 years ago

Closed 8 years ago

#8265 closed Bug (fixed)

First Word Backwards in IE

Reported by: Amanda Owned by:
Priority: Normal Milestone:
Component: General Version: 3.3.1
Keywords: Cc:

Description

Hi,

We use CKeditor on an internal portal, and recently have noticed that when using IE, the first word typed will be backwards until you hit the space bar. The only customizing I've done is about which items are displayed in the tool bar. I have no idea where to even start looking, and would appreciate any insight into this!

I added it to the portal last summer, and I don't think any of the developers have touched it since.

Thanks.

Attachments (2)

backwards_text.png (3.4 KB) - added by Amanda 8 years ago.
Screenshot
test.php (2.2 KB) - added by Amanda 8 years ago.
Test, sample file of backwards text

Download all attachments as: .zip

Change History (8)

Changed 8 years ago by Amanda

Attachment: backwards_text.png added

Screenshot

comment:1 Changed 8 years ago by Jakub Ś

Status: newpending

In IE if you set config.enterMode = CKEDITOR.ENTER_BR; and scayt_autoStartup:true, type some text, delete it and start typing again. If you write slowly enough (let's say letter wait until cursor moves left, letter ...) The word will be written backwards. I'm only aware of such issue. Yours sounds different but maybe it has something in common.

Could you provide more details like:

  1. What configuration settings have you used for your CKEditor.
  2. Is the version you have specified – 3.3.1 - is correct? If so than please try to upgrade to CKE 3.6.1 this product is much better and free from many bugs that previous releases had.
  3. Are you able to reproduce the issue in standalone CKEditor or only inside your application? If so than this might be your setting problem not CKEditor.
  4. What CKEditor are you using? Plain JS version or some sort of integration (Java, PHP)

comment:2 Changed 8 years ago by Jakub Ś

Keywords: backwards text removed

comment:3 in reply to:  1 Changed 8 years ago by Amanda

My config settings are pretty simple:

config.toolbar = 'MyToolbar';

config.toolbar_MyToolbar =
[
	['Bold', 'Italic', 'Underline', '-', 'JustifyLeft', 'JustifyCenter',
'JustifyRight', '-', 'NumberedList', 'BulletedList', '-',
'Link', 'Unlink', '-', 'About']
    ];
		
	config.removePlugins = 'elementspath';

Yes, 3.3.1 is the version number I found in the Change log.

I've done a stand alone page with only the CKeditor on it, and it does happen again. I thought it may be some of the other JavaScript I have on the page, but this stand alone page doesn't have any on it, so it doesn't seem to be that.

I think it's just the plain JavaScript version, but there are some PHP/ASP files.

I think I'm going to try 3.6.1 and see how that works out.

Thanks, --Amanda

Last edited 8 years ago by Amanda (previous) (diff)

comment:4 Changed 8 years ago by Jakub Ś

And could you provide this sample file? It would be a great help if the error is reproducible in current CKEditor.

Changed 8 years ago by Amanda

Attachment: test.php added

Test, sample file of backwards text

comment:5 in reply to:  4 Changed 8 years ago by Amanda

Done and done. (test.php)

comment:6 Changed 8 years ago by Amanda

Resolution: fixed
Status: pendingclosed

Looks like upgrading to 3.6.1 has fixed whatever was happening with the text.

Thanks for the help! :)

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy