Opened 11 years ago

Closed 8 years ago

#83 closed Task (fixed)

Move trackers from SourceForge to Trac

Reported by: Frederico Caldeira Knabben Owned by:
Priority: Must have (possibly next milestone) Milestone:
Component: General Version:
Keywords: Pending Cc:

Description (last modified by Frederico Caldeira Knabben)

The new dev site is finally ready and now we have a big and important task to be done. All trackers must be moved from SourceForge to the new system.

The following trackers must be moved:

Other trackers will be handled in a second moment.

For now, the above trackers will be disabled to public view. Only SF project members will have access to it.

Breaking the Task

For those interested on working in this task, just follow these advices so we can organize it better:

  • Open the tracker list, filter it for Status=Open and sort it by ID (Ascending);
  • Annotate the range of Request IDs you would like to work in;
  • Add a comment to this ticket like: "I'm working on bugs from XXX to YYY".

Of course, check first if no one is already working inside your range.

General Guidelines

  1. Open the report at SF. It is not required, but if possible, check that it is still valid, closing it if it's not (ignoring the next steps).
  1. Create a new ticket at Trac in another window, with the appropriate Type.
  1. Copy and paste the summary. Correct any typo or make it clearer, if needed.
  1. Copy and paste the report body. If possible, make it more readable (line breaks and code blocks, for example).
  1. At the end of the new ticket body, add the following:
----
Moved from SF:[[BR]]
http://sourceforge.net/tracker/index.php?....

The link should point to the relative report page at SF

  1. If possible, set the "Component" and "Version" fields. Avoid using "Priority" and "Milestone".
  1. Add "SF" to "Keywords".
  1. Save the new ticket.
  1. Download any attachment from the SF report and add it to the new ticket. In the Attachment Info, add the text:
{Attachment Description at SF, if any} Moved from SF. Original author: {SF user name for the attachment}
  1. Copy and paste every comment from the SF report, in a chronological order (older first). Ignore duplicates, vandalism and anything that adds no value to the ticket (like "Me too!"). After the original commend, add:
----
Moved from SF. Original poster: {SF user name or Anonymous}
  1. Reporter field (set to anonymous, if anonymous) and CC all comment posters (if not anonymous) using their SF user name, concatenated with @users.sourceforge.net. E.g.: fredck@….
  1. Set the Status of the original SF report to "Closed". At the same time, add a comment to that report in the following format:
This report has been moved to our new development site at:
http://dev.fckeditor.net/ticket/{ticket_ID}

Duplicates

Whenever possible, avoid moving duplicates, but don't ignore them. Instead follow these steps:

  1. Add a comment to the Trac ticket in this format:
The following SF report has been market as duplicate of this:
http://sourceforge.net/tracker/index.php?....
  1. If any useful comment (even the report body) or attachment is available, add it to the ticket as defined at points 9 and 10 in the above General Guidelines. In addition, add the SF report URL to the comment.
  1. Close the SF report as defined in the above point 11, using a comment in the following format instead:
This report has been marked as a duplicate of:
http://dev.fckeditor.net/ticket/{ticket_ID}

If the "Resolution" field is available at SF, set it to "Duplicate".

Patches

A patch is nothing else than a fix for a bug or an implementation of a new feature. So, we should just transform the patch to either a Bug or a New Feature ticket.

Change History (18)

comment:1 Changed 11 years ago by Frederico Caldeira Knabben

Ok... some people were confused because the SF trackers have been closed. I've so make then visible to the public, with a message indicating users to visit our new dev site.

comment:2 Changed 11 years ago by Frederico Caldeira Knabben

Description: modified (diff)

comment:3 Changed 10 years ago by Martin Kou

I'm working on feature requests from 725326 to 1187867

comment:4 Changed 10 years ago by Martin Kou

I'm working on bugs from 780078 to 1380192

comment:5 Changed 10 years ago by Martin Kou

I'm working on bugs from 1391450 to 1511448

comment:6 Changed 10 years ago by Martin Kou

I'm working on bugs from 1511456 to 1649163

comment:7 Changed 10 years ago by Martin Kou

I'm working on bugs from 1650118 to 1675277

comment:8 Changed 10 years ago by Martin Kou

I'm working on feature requests from 1188944 to 1403554

comment:9 Changed 10 years ago by Martin Kou

I'm working on feature requests from 1403830 to 1547151

comment:10 Changed 10 years ago by Alfonso Martínez de Lizarrondo

All the feature request have been moved.

comment:11 Changed 10 years ago by Frederico Caldeira Knabben

That's wonderful Alfonso. I've closed the tracker at SF. Now, just Patches and Plugins are still missing.

BTW, would it be nice to handle the Plugins here too, opening a new ticket type? We could also create a page that lists all the tickets.

comment:12 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Don't forget also about the Skins.

About the plugins: I suggested some time ago to have a "plugins showcase" page (http://dev.fckeditor.net/wiki/Ideas#Plugins) so people can discover and understand them better.

I'm not sure if a ticket is the best way to handle a plugin. I think that it might be slightly better to have a wiki page based on some template and ideally a link to a current version of the editor with that plugin included.

Back to the Patches: it would be good if you or Wiktor could take a look about the ones on PHP and the like because they refer to old versions and I don't know if they have something useful or it isn't worth the effort to move them because they are currently invalid.

comment:13 Changed 10 years ago by Wojciech Olchawa

Resolution: fixed
Status: newclosed

comment:14 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Resolution: fixed
Status: closedreopened

There are still some patches missing, as well as the plugins and skins.

comment:18 Changed 9 years ago by Artur Formella

Keywords: Confirmed added

comment:19 Changed 8 years ago by Artur Formella

Keywords: Pending added; Confirmed removed

Isn't it done?

comment:20 Changed 8 years ago by Alfonso Martínez de Lizarrondo

You can see that there are still 23 patches pending: http://sourceforge.net/tracker/?group_id=75348&atid=543655 Nobody has worked on them all this time.

And of course, the skins and plugins are all still there

comment:21 in reply to:  20 Changed 8 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: reopenedclosed

Replying to alfonsoml:

Nobody has worked on them all this time.

That tracker is outdated. If you can find anything useful for us there, just let us know.

And of course, the skins and plugins are all still there.

Yes, that's the main reason for having this one opened. The things is that we'll have a dedicated repository for V3, so it looks like SF will remain as a resource for V2 users.

We can close this one at this point.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy