Opened 8 years ago

Closed 6 years ago

#8350 closed Bug (fixed)

Undo adds NBSP to empty paragraph

Reported by: Garry Yao Owned by:
Priority: Normal Milestone:
Component: Core : Undo & Redo Version: 3.0
Keywords: Cc:

Description

  1. Load any of the sample page;
  2. Press enter twice at the end of first paragraph (to create two new paragraphs)
  3. Undo once
  • Actual: Checked the last paragraph, it contains a NBSP text node now.

Change History (4)

comment:1 Changed 8 years ago by Garry Yao

The bad thing of NBSP in wysiwyg is that the check start/end of block logic cannot handle it well, so enter key behavior inside a block which affects by it will probably break.

comment:2 Changed 8 years ago by Garry Yao

For those who dont have the background, we've eliminated the NBSP usage (as filler node) in modern IE back in #6248.

comment:3 Changed 8 years ago by Jakub Ś

Keywords: IE removed
Status: newconfirmed

I not sure why have you added IE keyword since the issue is reproducible in all browsers

comment:4 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

I could not reproduce it on IE8 or Chrome on 4.3.3.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy