Opened 12 years ago

Closed 12 years ago

#841 closed New Feature (invalid)

Documentation inside the Package

Reported by: undisclosed@… Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: SF Cc:

Description

Greetings, There is NO documentation included in the archive of this project - not even so much as a README or INSTALL file. There is some silly _documentation.html which is only a URL. 2 problems with this URL file:

1) What if you want to use this in an INTRAnet environment w/o connection to the INTERnet? The _documentation.html won't help.

2) This URL points to a wiki. Not very helpful in a development environment.

... OK 3 problems...

3) How will this URL help a new administrator/ user with setup/ installation of this editor in their environment?!

This is like providing the install documentation for Windows/ BSDi/ Linux as a URL to the OS website.

SHEESH! What in the heck is the problem with including documentation with this project?!?

I vote NO for using this project until the doc's are included - or at least as a downloadable archive. c'mon guys, get a grip.


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1313399&group_id=75348&atid=543656

Change History (2)

comment:1 Changed 12 years ago by Martin Kou

Reporter: changed from Martin Kou to undisclosed@…

comment:2 Changed 12 years ago by Wojciech Olchawa

Resolution: invalid
Status: newclosed

SHEESH! What in the heck is the problem with including documentation with this project?!?

The problem is that the documentation would take a lot of space and would not be lightweight. If we would include the docs in the FCKedtior project download pack than the amount of space taken by the program on the server would increase rapidly. Our goal is to make the editor take less space not the opposite.

What if you want to use this in an INTRAnet environment w/o connection to the INTERnet? The _documentation.html won't help.

Of course the _documentation.html won't help however you have to have an internet connection to download the editor so you can also use it to view the docs for the integration process.

How will this URL help a new administrator/ user with setup/ installation of this editor in their environment?!

Well I think it will help an administrator very much because the docs provide instructions how to integrate FCKeditor in many server side languages:

http://docs.fckeditor.net/FCKeditor_2.x/Developers_Guide

...or at least as a downloadable archive.

Maybe it would be a good idea but remember that FCKeditor is an open source project and everyone can participate in it which also includes participating with building the documentation. Every user can add his comments and examples to the docs which makes the docs better and more useful.

I vote NO for using this project until the doc's are included

Remember the difference between open source projects and commercial projects. In open source not everything has to be the same way as if in commercial releases.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy