Opened 8 years ago

Closed 8 years ago

#8431 closed Bug (invalid)

CKFinder thumbnail creation in sub-folders of a 2nd-level folder not working

Reported by: Jonny N Owned by:
Priority: Normal Milestone:
Component: File Browser Version:
Keywords: Cc:

Description

If CKFinder is being used to browse an *existing* folder structure of images for the first time, and is therefore creating thumbnails on-the-fly whilst exploring the folders therein, it *won't* create thumbnails for images in sub-folders of a folder that contains no images (only sub-folders) itself. For example:

Images/folderX
+ folderA
( imageA.gif)
+ folderB
( imageB.gif)

..when you navigate into 'folderA' or 'folderB', thumbnails for 'imageA.gif' and/or 'imageB.gif' don't get created, seemingly because 'folderX' itself doesn't contain any images, only the sub-folders 'folderA' and 'folderB'.

The same behaviour exhibits for further levels of folder nesting (e.g. in 'folderA' or 'folderB' had further sub-folders within them).

As I mentioned already, this behaviour *only* occurs when exploring an existing nested folder structure of images and sub-folders for the first time with CKFinder. When folders are created or images uploaded by CKFinder itself, thumbnails are created as expected.

Bug exhibits regardless of which browser is being used, tested on many! I'm using the PHP connector.

When such a sub-folder is navigated to, the file browser sends a request to the connector for the thumbnail, but the response is always empty. This appears to be because the parent sub-folder doesn't exist within the thumbnails directory (as it hasn't been created, as 'folderX' has no images in). The connector back-end should cope with this scenario and recursively create the required sub-folders in the thumbnails directory if they don't exist.

Change History (10)

comment:1 Changed 8 years ago by Jonny N

If you manually create the 'missing' in-between sub-folders in the thumbnails folder, all is well ;)

comment:2 Changed 8 years ago by Jakub Ś

Status: newpending

@jonnott I could not reproduce the issue. Here are my steps.

  1. I have put pictures in second-level folders
  2. Stopped the server
  3. Went to userfiles and removed all the thumbs but left the folders structure. In second try I have removed the whole thumbs folder.

In both cases when I started the server and went to second-level folders thumbs were created and thus visible in browser.

Could you tell me if I have missed something in above steps?

comment:3 in reply to:  2 Changed 8 years ago by Jonny N

I'm specifically referring to what are effectively 'third'-level (Images/2nd/3rd/) folders inside a 'second'-level folder (Images/2nd/), where the 2nd-level folder contains *nothing* apart from a 3rd-level folder (that is, the 2nd-level folder has no images of its own).

Starting with an empty thumbnails directory, thumbnails don't seem to get created for the 3rd-level folder's images, *unless* the 2nd-level parent folder itself contains at least one image file for which a thumbnail has been created.

What appears to be happening is this (assuming a thumbnails directory called '_thumbs'):

  • if you view the contents of Images/2nd/3rd/, it will try to create _thumbs/Images/2nd/3rd/xxxxx.jpg
  • but if _thumbs/Images/2nd/ hasn't already been created by another thumbnail creation request within /2nd/ itself
  • then creating a thumbnail in _thumbs/2nd/3rd/ will fail

If you're saying this exact scenario isn't re-creatable, then perhaps there's something wrong with my environment somewhere. But this seems unlikely, as *every other aspect* of thumbnail behaviour works exactly as expected for me..

comment:4 Changed 8 years ago by Jakub Ś

Version: 3.6.2

Still nothing. Every time I test this thumbs are created.

  1. I have put pictures in third-level folder
  2. Stopped and Started the server / refreshed only browser after removing thumbs form folders
  3. Went to userfiles and removed all the thumbs but left the folders structure / removed the whole thumbs folder / removed all the folders thumbs except for _thumbs.
  1. Could I ask you in which browser does the issue occur?
  2. Which version of CKFinder are you using (should be latest 2.1)?
  3. In which sample for CKFinder is the issue reproducible – standalone/popup/ckeditor integration etc. ?

comment:5 Changed 8 years ago by Jakub Ś

@jonnott have you got any updates regarding this issue?

Could I ask you which CKFinder are you using JAVA/ASP/PHP?

comment:6 Changed 8 years ago by Jonny N

It's the PHP version.

I'll do some more checking...

comment:7 Changed 8 years ago by Jakub Ś

Thanks. I'll wait for your results.

I have also asked my colleague to check it and he also had no errors. Could it be perhaps something in permission rights to those folders? Perhaps it is something in your config file – you think you might send it to us?

comment:8 Changed 8 years ago by Jakub Ś

@jonnott have you got any updates?

Does the issue occur with default freshly downloaded CKFinder or it occurred after you have done some customizations?

Last edited 8 years ago by Jakub Ś (previous) (diff)

comment:9 Changed 8 years ago by Jonny N

Yeah, the problem appears to be a problem with my specific setup. I've tried it running on my local machine with MAMP, and all works as expected.

Sorry to have wasted peoples' time, you can close this bug!

comment:10 Changed 8 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy