Opened 8 years ago

Closed 8 years ago

#8442 closed New Feature (duplicate)

Block (i.e. not inline) <a> tags

Reported by: MarkS Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

With HTML5 anchor tags are now valid block elements

e.g. The following is perfectly valid

<a href="">
<img src="" alt="" />
<h1>Some Text</h1>
</a>

However, with CKEditor, the cleanup converts it to

<a href=""><img src="" alt="" /></a>
<a href=""><h1>Some Text</h1></a>

I'm requesting that the requirement for <a> tags to be inline elements is removed

Change History (2)

comment:1 Changed 8 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 8 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

It seems that it's a duplicate of #7961

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy