Opened 8 years ago

Closed 8 years ago

#8480 closed Bug (fixed)

Dropdown menu's for Styles, Format, Font and Size not working correctly in IE8

Reported by: Sander van den Berg Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.2
Keywords: Cc:

Description

Hello

CKEditor is integrated in my company's CMS. Since then i also integrated it in my own websites and i still love it.

I myself don't work with IE but a college of mine came with the following, which i tested in our CMS, with latest release version (http://ckeditor.com/demo) and the Nightly version:

  • Click in IE8 on one of the dropdown menu-options there are (Styles, Format, Font or Size)

The first time the page gives you a reload or a long loading activity

  • Again click on one of the dropdown menu-option, nothing happens
  • Click a third time on the dropdown menu-option, the menu does show but collapses back to only 1 option it shows
  • When u click a fourth time, the menu actually shows

Attachments (1)

screenshot dropdown.png (63.9 KB) - added by Sander van den Berg 8 years ago.

Download all attachments as: .zip

Change History (9)

Changed 8 years ago by Sander van den Berg

Attachment: screenshot dropdown.png added

comment:1 Changed 8 years ago by Jakub Ś

Status: newpending

I have tried the demo and the latest nightly and nothing unexpected happened.

Could you tell me:

  • What operating system aru you using?
  • Are you using IE8 with some third party plugins that might collide with CKEditor and causing the error
  • Perhaps I have missed something while reproducing the bug. Do you click on different dropdowns or every time on the same. How do you close the dropdown - click on it again or perhaps click outside the editor?

Any details are welcome.

comment:2 Changed 8 years ago by Sander van den Berg

  • The current problem shows itself under Windows 7 64-bit with IE8
  • No thirdparty plugins or bars are installed, i did notice some office plugins but i now have everything disabled and it still shows itself
  • The problem shows itself clicking either on the same dropdown or different each time.
  • Because the dropdown doesn't show up till the 4th click, i don't close the dropdown. It also doesn't matter clicking on the part of the word / option or on the arrow-icon

I will test it again at home with differences in network and Win7 version but i think i had the same issue there

comment:3 Changed 8 years ago by Jakub Ś

which i tested in our CMS, with latest release version (http://ckeditor.com/demo) and the >Nightly version:

@NightElf81 - I didn't read your post carefully and assumed you have tested the issue in our demo site (http://ckeditor.com/demo) or site for latest nightly (http://nightly.ckeditor.com/demo ) but you have done all the testing in your CMS.

Could I ask you to check the issue in our demo site or latest nightly and see if the issue occurs there? If not than this issue is related to your CMS and not CKEditor.

Waiting for your comments.

comment:4 Changed 8 years ago by Sander van den Berg

Appolgies for not being clear, but i did mean your (the ckeditor) demo and Nightly version

I did that first to check if it was not just my CMS

comment:5 Changed 8 years ago by Jakub Ś

Checked on two different computers and no problem found.

Could it be perhaps due to your slow connection, antivirus, security settings in IE or something similar?

Could you tell me if you're getting any errors when this happens?

comment:6 Changed 8 years ago by Jakub Ś

@NightElf81 have you got any updates regarding this bug?

comment:7 Changed 8 years ago by Sander van den Berg

I have now tested it on multiple computers but indeed no bug shows there Seems it has to do with Win7 and IE in a cloud network

comment:8 Changed 8 years ago by Sander van den Berg

Resolution: fixed
Status: pendingclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy