Opened 7 years ago

Closed 7 years ago

#8592 closed Bug (invalid)

FF: <br> tag added to each table cell when a table is created

Reported by: Teresa Monahan Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: IBM Cc: Damian, Satya Minnekanti

Description

To Reproduce:
Open any CKEditor sample in FF and insert a table.
Inspect the table that was created using Firebug.
Problem: Each cells contains a <br> tag.

When you enter text in one of the cells and then switch to Source view and back to wysiwyg mode, the <br> tag is no longer present in that cell.

Is there a reason for adding these <br> tags in FF?

Attachments (2)

FF table br tags.jpg (17.2 KB) - added by Teresa Monahan 7 years ago.
8592.png (31.6 KB) - added by Jakub Ś 7 years ago.

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by Teresa Monahan

Attachment: FF table br tags.jpg added

comment:1 Changed 7 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 3.6.3 (SVN - trunk)

We fill tables with empty br's.

Take a look at: _source\plugins\table\dialogs\table.js:

if ( !CKEDITOR.env.ie )
	cell.append( makeElement( 'br' ) );

This is because nonIE browsers have problems with displaying empty table cells. It can be best observed in Firefox Firebug and Opera Dragonfly.

Take a look at 8592.png and see what happens when you delete those br nodes. What is more when you click inside such empty cell Firefox adds its own br inside (<br type="_moz">)

Please reopen this issue if you don't agree with my opinion.

Changed 7 years ago by Jakub Ś

Attachment: 8592.png added
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy