Ticket #8601 (closed Bug: expired)

Opened 2 years ago

Last modified 2 years ago

Page slow in Firefox with multiple instances and Format Tag in toolbar

Reported by: qqluq Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.2
Keywords: Cc:

Description

When I put multiple CKeditor instances on one page the page becomes very slow for example if you are scrolling down on the page. When i remove the 'Format' tool in the toolbar, the page is fast. This is in Firefox for Mac.

Attachments

test8601.txt (8.0 KB) - added by j.swiderski 2 years ago.
replacebycode2.html (6.9 KB) - added by j.swiderski 2 years ago.

Change History

comment:1 Changed 2 years ago by j.swiderski

  • Status changed from new to pending

Could I ask you for more information here:

  1. How many instances do you have on page?
  2. What is 'Format' tool? Which plugin(s) do you remove?
  3. Would it possible to send this ample page you have created?
  4. Which version of Firefox and MAC are you using?

comment:2 Changed 2 years ago by qqluq

  1. 5 or more instances (compile a newsletter with multiple blocks)
  2. The format options is available in the standard toolbar. To choose for example p, h1, h2, etc.
  3. I don't have an example because its behind a login.
  4. I use the latest Firefox and Mac OSX, the version before Lion.

Changed 2 years ago by j.swiderski

Changed 2 years ago by j.swiderski

comment:3 Changed 2 years ago by j.swiderski

I have attached two files on which I have tested the issue.

I have put the HTML file in samples folder and then pasted into every instance (in Source mode) of CKEditor the code attached in txt file.
There was no difference no matter if I used format plugin or not.

Could you tell me if you are able to reproduce the issue on your Computer with my test case files? If not then could you tell me what have I missed, what is wrong with my approach.

I don't have an example because its behind a login.

I'm not asking you for any company sensitive data. You can prepare test case file containing some dummy text.
Perhaps some special HTML structure of this news letter is causing this but instead of me guessing how it should look like, I think we both agree on this, it would be better if you could send it to us. How are we suppose to fix a bug if we can’t reproduce it in the first place?

Waiting for your comments.

comment:4 Changed 2 years ago by j.swiderski

  • Status changed from pending to closed
  • Resolution set to expired
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy