Opened 8 years ago

Closed 4 years ago

#8639 closed Bug (wontfix)

Safari can't handle tables pasted from Excel

Reported by: Jakub Ś Owned by:
Priority: Normal Milestone:
Component: Plugin : Paste from Word Version: 3.0
Keywords: Safari Cc:

Description (last modified by Jakub Ś)

Issue has been reproducible from CKEditor 3.0 Tested on Safari 5.1

To reproduce:

  1. Copy table form any of the attached Excel files
  2. Paste this table into CKEditor using CRTL+V, paste buttorn or paste from word button

Result: Table gest pasted as text.

<p>
	&nbsp; &nbsp; &nbsp;a b c d &nbsp;</p>

Edit: I have just checked this in Safari on Windows in plain contenteditable div. It seesm that Safari only sees text. There nothing CKEditor can do here.

Attachments (2)

8594.xls (13.5 KB) - added by Jakub Ś 8 years ago.
8594.xlsx (9.5 KB) - added by Jakub Ś 8 years ago.

Download all attachments as: .zip

Change History (8)

Changed 8 years ago by Jakub Ś

Attachment: 8594.xls added

Changed 8 years ago by Jakub Ś

Attachment: 8594.xlsx added

comment:1 Changed 8 years ago by Jakub Ś

Status: newconfirmed

This ticket has also been described in #6465 which also tackles problem with pasting from Excel

comment:2 Changed 8 years ago by swetha_java

This issue still persist in CkEditor 3.6.2. Tested in IE 7, IE 9

Lost table format, when copy from Excel to Editor using Paste, ctrl-v, Paste from Word.

I am using config.pasteFromWordRemoveStyles=false; which preserving format from MS Word.

Do I need to use any special configuration to preserve the Excel format, when I copy.

comment:3 Changed 7 years ago by Jakub Ś

Description: modified (diff)

comment:4 Changed 7 years ago by Jakub Ś

@swetha_java you should use both options:

config.pasteFromWordRemoveFontStyles=false;
config.pasteFromWordRemoveStyles = false; 

Nevertheless, IE being best in transferring data from Excel it still loses some attributes. Browser always gets to data before JavaScript thus there is nothing we can do here.

comment:5 Changed 6 years ago by Frederico Caldeira Knabben

Component: GeneralPlugin : Paste from Word

comment:6 Changed 4 years ago by Jakub Ś

Resolution: wontfix
Status: confirmedclosed

Ok, I think it is time to close this ticket. Safari 5.1 is dead and bug mentioned here was in fact Safari bug.

At the moment pasting from excel is not supported but this is because browsers other than IE have problems with that content.

General issue has been reported here: #13623.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy