Opened 7 years ago

Closed 6 years ago

#8648 closed Bug (worksforme)

Unable to place cursor in correct position on Android Browser 3.2

Reported by: Rob Owned by:
Priority: Normal Milestone:
Component: Core : Selection Version: 3.6.2
Keywords: Android Cc:

Description

Using CKeditor on an Android tablet, I was unable to select the correct position in the text.

Tapping on the text would highlight all the content briefly before placing the cursor at some point earlier than the position selected. The Cursor seemed to be "more wrong" the long the text got (it was pretty close near the top, and several paragraphs early near the end of a 200 word article).

Steps to reproduce:

-> Go to ckeditor.com/demo (or one of the nightly demos) on an Android tablet. -> Type until the text is long than the textarea -> Try to tap to put the cursor in another position in the text.

Change History (5)

comment:1 Changed 7 years ago by Alfonso Martínez de Lizarrondo

Yes, sometimes I noticed that problem while testing an Asus Transformer, but I think that the problem lies in Android, as that's the one that takes care of positioning the caret.

You should try to file an issue at their tracker: http://code.google.com/p/android/issues/list stating that it's related to contentEditable

comment:2 Changed 7 years ago by Frederico Caldeira Knabben

Version: 3.6.3 (SVN - trunk)3.6.2

comment:3 Changed 7 years ago by Jakub Ś

NOTE:

I have tried to reproduce the problem on android emulator:
http://buildcontext.com/blog/2011/android-browser-emulator-windows-7-nexus-s-xoom-tablet
but with no luck. Cursor was always positioned where I clicked.

comment:4 Changed 6 years ago by Jakub Ś

Keywords: Android added

comment:5 Changed 6 years ago by Anna Tomanek

Resolution: worksforme
Status: newclosed

Works for me in stock browser in Android 4.2.1 (Jelly Bean). The cursor is placed correctly.

Please re-open if you find that it does not work in a version newer than 4.2.1.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy