Opened 6 years ago

Closed 6 years ago

#8803 closed Bug (fixed)

CKFinder config.id parameter passed with double ampersand in querystring

Reported by: Philippe Meunier Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

When we give an id to ckfinder (v 2.0.2), it gets passed correctly to the popup window, but if we upload a new file, the POST request has the id parameter wrongly URLEncoded, the ampersand is added twice before the id, giving something like :

http://domain.com/includes/ckfinder/core/connector/asp/connector.asp?command=FileUpload&type=Images&currentFolder=%2F&langCode=fr&hash=50073e42bf738bd2'''&&'''id=filepicker-simple-editor

Here is the code snippet to reproduce the bug :

var finder = new CKFinder({
  "id": "filepicker-simple-editor",
  "basePath" : "/includes/ckfinder/"
});

finder.popup();

Attachments (1)

test.asp (684 bytes) - added by Philippe Meunier 6 years ago.
Example code to reproduce the bug

Download all attachments as: .zip

Change History (4)

comment:1 Changed 6 years ago by Jakub Ś

Keywords: ckfinder removed
Status: newpending
  1. Could you send us the file(s) in which you have made this integration? We would like to see it for ourselves.
  2. Have you tried the latest CKEditor 2.1.1 does the problem occur there?
  3. Why are you using double quotes on config object E.g. "id": "filepicker-simple-editor", ? This is not JSON object but JavaScript object - there is no need for that.
  4. Does removing id works or perhaps double ampersands or single ampersand shows up at the end ? If so than perhaps you have made some made some error in one of your paths you have defined?

Changed 6 years ago by Philippe Meunier

Attachment: test.asp added

Example code to reproduce the bug

comment:2 Changed 6 years ago by Philippe Meunier

  1. I attached a file which is a very simple case where the bug occurs
  1. I installed the latest version (2.1.1) for Classic ASP and the problem still occurs
  1. The resulting object is the same (JSON is JavaScript Object Notation) but in the example file I uploaded, I changed it to remove double quotes around properties
  1. Removing the id makes the querystring ending with an ampersand : ...blablabla&hash=50073e42bf738bd2&

comment:3 Changed 6 years ago by Philippe Meunier

Resolution: fixed
Status: pendingclosed

Oh... sorry there I retested it... my js file was cached from a previous version, the problem is fixed with ckfinder 2.1.1

Thank you

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy