Ticket #8871 (closed Bug: expired)

Opened 2 years ago

Last modified 22 months ago

Strange problem with image plugin in Opera

Reported by: insad Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Opera Cc:

Description

Open the demo at http://ckeditor.com/demo in Opera (using: version 11.62, build 1347, Win32, Windows 7).

  1. Insert a new image like this (GoDaddy hosted site): http://www.green-bamboo.com/uploads/10/bamboo.png and Ok.
  2. Double click on the image; the image plugin opens, image is loaded but Opera keeps trying to load the image (see attached screenshot), the ImagePreviewLoader skim isn't removed.
  3. Close the image plugin popup window.
  4. Double click again on the image, now the plugin loads without any problem!
  5. Close the image plugin popup window again.
  6. Double click again on the image, the plugin loads with the same problem as in 2.

This is an on/off question, one time loads ok, the next time with the problem!

But it only seems to happen with images coming from some servers; the CKEditor demo image always works ok!

I tried to debug it and find a work around, but couldn't come any further than finding out somehow onImgLoadEvent isn't called in the txtUrl onChange handler. Strange is the on/off behaviour here, doesn't work / works / doesn't work ... !

Attachments

image.png (373.1 KB) - added by insad 2 years ago.

Change History

Changed 2 years ago by insad

comment:1 Changed 2 years ago by j.swiderski

  • Keywords Opera added; Opera, image plugin removed
  • Status changed from new to pending
  • Version 3.6.2 deleted

I was not abe to reproduce your problem. I have tried many different combinations - on demo page, on my local server, with this picture opened in other tab etc. but none of this resulted in error.

have you tried checking this image on other Opera instance - maybe this is due to some plugin/add-on you have installed in Opera which is causing that? Have you tried it in the default Opera?

Just to make sure - when you said

Insert a new image like this (GoDaddy hosted site): http://www.green-bamboo.com/uploads/10/bamboo.png and Ok.

You have meant inserting link into URL filed of Image dialog?

comment:2 Changed 22 months ago by j.swiderski

  • Status changed from pending to closed
  • Resolution set to expired
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy