Opened 8 years ago

Closed 5 years ago

#8929 closed Bug (fixed)

Scayt causes list formatting issues

Reported by: Ben Owned by:
Priority: Normal Milestone:
Component: UI : Spell Checker Version: 3.0.2
Keywords: Firefox Webkit Cc: WebSpellChecker.net

Description

I am using CKEditor on Firefox 11.0 on a windows server 2008 build.

I have enterMode and shiftEnterMode set to CKEDITOR.ENTER_BR.

When I add a ordered or unordered list to my document and have a line of text following the list, Scayt surrounds the line of text in a span after a load from the database and causes the editor to create a new unordered list with the last word from the last element of the list.

Disabling Scayt removes the issue.

Change History (4)

comment:1 Changed 8 years ago by WebSpellChecker.net

WebSpellChecker.net team confirms the problem for the enterMode = CKEDITOR.ENTER_BR for FF and WebKit.

comment:2 Changed 8 years ago by Jakub Ś

Cc: WebSpellChecker.net added
Keywords: Firefox Webkit added; spell checker list element unordered list ordered list removed
Status: newconfirmed
Version: 3.6.33.0.2

To reproduce

  1. Open AJAX sample
  2. insert list (E.g. 3 elements with some text) and escape it with double enter.
  3. under list type some text
  4. enable SCAYT (wait for the words to get underlined)
  5. REMOVE Editor
  6. Create editor
  7. Enable SCAYT.

Reproducible from CKEditor 3.0.2

comment:3 Changed 5 years ago by Wiktor Walc

Status: confirmedpending

@j.swiderski can you confirm that the issue is gone? See https://github.com/WebSpellChecker/ckeditor-plugin-scayt/issues/40

comment:4 Changed 5 years ago by Jakub Ś

Resolution: fixed
Status: pendingclosed

Seems to be working fine.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy