Opened 6 years ago

Closed 6 years ago

#8931 closed Bug (duplicate)

Focus editor with content in FF not consistent with other browsers (sets caret at end of document)

Reported by: Pieter Fibbe Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.3
Keywords: Cc:

Description

In Firefox when focussing the editor after setting data the caret positions at the end of the document. This is not consistent with other browsers' behaviour, in which the the caret is positioned at the beginning of the document (preferred behaviour).

To reproduce a button is made to fire the focus event because from the debug console it's not possible to focus the editor.

CKEDITOR.appendTo('demoInside', { height: 300 });

jQuery("<div />").text("CLICK ME TO FOCUS").click(function(){
    var editor = CKEDITOR.instances.editor2;
    editor.setData("line1<br/>line2");
    editor.focus();
}).appendTo("#demoInside");

Found in 3.6.3, but probably earlier as well.

Change History (1)

comment:1 Changed 6 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed

DUP of #8548

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy