Opened 7 years ago

Closed 5 years ago

#9006 closed Bug (duplicate)

Blank line added when using meta tag

Reported by: Roi Zaig Owned by:
Priority: Normal Milestone:
Component: General Version: 3.5.3
Keywords: Cc: mickycs@…

Description

If using a 'meta' tag in the html source and switching between source view and rendered view (not source view), a 'p' tag is added as follows:

Input source: <meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />

After to switching rendered view and switching back to source view: <p>

&nbsp;</p>

<p>

<meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />

</p>

This creates an empty line at the top of the document.

Change History (4)

comment:1 Changed 7 years ago by Jakub Ś

Keywords: meta removed
Status: newconfirmed
Version: 3.5.3

Please use fullPage mode for that:
http://docs.cksource.com/ckeditor_api/symbols/CKEDITOR.config.html#.fullPage Meta tags can only be inserted in head section (http://www.w3schools.com/tags/tag_meta.asp).


Nevertheless there shouldn't be any new paragraphs added when switching to source and back. I haven't found any duplicate so I’m confirming this ticket.

From CKEditor 3.0 till 3.0.2 meta tag was left untouched in paragraph (which allso seemed to me as good approach - ignoring == user friendly).

From CKEditor 3.1 till 3.5.3 rev. [6559] meta tag was removed from paragraph and pasted below it. Appart from that it was left untouched (which allso seemed to me as good approach - ignoring == user friendly).

From CKE 3.5.3 rev. [6561] to CKE 3.5.3 rev. [6628] meta tag was removed (which seemed correct as meta tags are not allowed in HTML4 in body (In HTML5 they are allowed as microdata) but such approach is not user friendly)

From CKE 3.5.3 rev [6629] meta tag gets wrapped in paragraphs and new empty paragraph is being added each time you switch modes.

Last edited 7 years ago by Jakub Ś (previous) (diff)

comment:2 Changed 7 years ago by Jakub Ś

Other tickets where meta tags also cause problems: #8117, #9186.

comment:3 Changed 5 years ago by Mick

Anyone using Wistia or other services to embed video using HTML5 "stuff" will have problems. Here is the code to embed one of our videos. When switching between views (or worse...when it loads from being saved previously), it closes the two initial divs early and puts everything after them. I hope this helps.

<div id="wistia_18anv5zo10" class="wistia_embed" style="width:640px;height:360px;">
<div itemprop="video" itemscope itemtype="http://schema.org/VideoObject">
<meta itemprop="name" content="New Look For EstateSales.NET" />
<meta itemprop="duration" content="PT1M46S" />
<meta itemprop="thumbnailUrl" content="https://embed-ssl.wistia.com/deliveries/8bdfbd0d006b8db7fc6e5860fbcc74b07aea1060.bin" />
<meta itemprop="contentURL" content="https://embed-ssl.wistia.com/deliveries/8c5a55a1afc0538309afccb4e3b61bc5b9bf4c78.bin" />
<meta itemprop="embedURL" content="https://embed-ssl.wistia.com/flash/embed_player_v2.0.swf?2013-10-04&autoPlay=false&banner=false&controlsVisibleOnLoad=true&customColor=7b963e&endVideoBehavior=default&fullscreenDisabled=true&hdUrl%5B2pass%5D=true&hdUrl%5Bext%5D=flv&hdUrl%5Bheight%5D=720&hdUrl%5Bsize%5D=35071743&hdUrl%5Btype%5D=hdflv&hdUrl%5Burl%5D=https%3A%2F%2Fembed-ssl.wistia.com%2Fdeliveries%2F140c9faa031f2fb7fe0b36d4e79ac22639cced43.bin&hdUrl%5Bwidth%5D=1280&mediaDuration=106.0&playButtonVisible=true&showPlayButton=true&showPlaybar=true&showVolume=true&stillUrl=http%3A%2F%2Fembed.wistia.com%2Fdeliveries%2F8bdfbd0d006b8db7fc6e5860fbcc74b07aea1060.jpg%3Ft%3D1378914829851%26image_crop_resized%3D640x360&unbufferedSeek=false&videoUrl=https%3A%2F%2Fembed-ssl.wistia.com%2Fdeliveries%2F8c5a55a1afc0538309afccb4e3b61bc5b9bf4c78.bin" />
<meta itemprop="uploadDate" content="2013-09-10T15:47:09Z" />
<object id="wistia_18anv5zo10_seo" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" style="display:block;height:360px;position:relative;width:640px;">
<param name="movie" value="https://embed-ssl.wistia.com/flash/embed_player_v2.0.swf?2013-10-04"></param><param name="allowfullscreen" value="true"></param>
<param name="bgcolor" value="#000000"></param><param name="wmode" value="opaque"></param>
<param name="flashvars" value="autoPlay=false&banner=false&controlsVisibleOnLoad=true&customColor=7b963e&endVideoBehavior=default&fullscreenDisabled=true&hdUrl%5B2pass%5D=true&hdUrl%5Bext%5D=flv&hdUrl%5Bheight%5D=720&hdUrl%5Bsize%5D=35071743&hdUrl%5Btype%5D=hdflv&hdUrl%5Burl%5D=https%3A%2F%2Fembed-ssl.wistia.com%2Fdeliveries%2F140c9faa031f2fb7fe0b36d4e79ac22639cced43.bin&hdUrl%5Bwidth%5D=1280&mediaDuration=106.0&playButtonVisible=true&showPlayButton=true&showPlaybar=true&showVolume=true&stillUrl=http%3A%2F%2Fembed.wistia.com%2Fdeliveries%2F8bdfbd0d006b8db7fc6e5860fbcc74b07aea1060.jpg%3Ft%3D1378914829851%26image_crop_resized%3D640x360&unbufferedSeek=false&videoUrl=https%3A%2F%2Fembed-ssl.wistia.com%2Fdeliveries%2F8c5a55a1afc0538309afccb4e3b61bc5b9bf4c78.bin"></param>
<embed src="https://embed-ssl.wistia.com/flash/embed_player_v2.0.swf?2013-10-04" allowfullscreen="true" bgcolor=#000000 flashvars="autoPlay=false&banner=false&controlsVisibleOnLoad=true&customColor=7b963e&endVideoBehavior=default&fullscreenDisabled=true&hdUrl%5B2pass%5D=true&hdUrl%5Bext%5D=flv&hdUrl%5Bheight%5D=720&hdUrl%5Bsize%5D=35071743&hdUrl%5Btype%5D=hdflv&hdUrl%5Burl%5D=https%3A%2F%2Fembed-ssl.wistia.com%2Fdeliveries%2F140c9faa031f2fb7fe0b36d4e79ac22639cced43.bin&hdUrl%5Bwidth%5D=1280&mediaDuration=106.0&playButtonVisible=true&showPlayButton=true&showPlaybar=true&showVolume=true&stillUrl=http%3A%2F%2Fembed.wistia.com%2Fdeliveries%2F8bdfbd0d006b8db7fc6e5860fbcc74b07aea1060.jpg%3Ft%3D1378914829851%26image_crop_resized%3D640x360&unbufferedSeek=false&videoUrl=https%3A%2F%2Fembed-ssl.wistia.com%2Fdeliveries%2F8c5a55a1afc0538309afccb4e3b61bc5b9bf4c78.bin" name="wistia_18anv5zo10_html" style="display:block;height:100%;position:relative;width:100%;" type="application/x-shockwave-flash" wmode="opaque">
</embed>
</object>
<noscript itemprop="description">We are updating the look and feel of EstateSales.NET. We can't wait for you to check out the new responsive design. It looks great on phones, tablets, PCs, Macs, etc.</noscript>
</div>
</div>
<script charset="ISO-8859-1" src="//fast.wistia.com/assets/external/E-v1.js"></script>
<script>
wistiaEmbed = Wistia.embed("18anv5zo10", {
  videoFoam: true
});
</script>
<script charset="ISO-8859-1" src="//fast.wistia.com/embed/medias/18anv5zo10/metadata.js"></script>

comment:4 Changed 5 years ago by Piotrek Koszuliński

Resolution: duplicate
Status: confirmedclosed

This is a duplicate of #8117. There's no reason to keep both, so I'm closing this one.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy