Opened 3 years ago

Closed 3 years ago

#9047 closed Bug (fixed)

Links created using Links plugin to anchor tag does not work

Reported by: Rajasimhan Owned by: fredck
Priority: Normal Milestone: CKEditor 3.6.4
Component: General Version: 3.0
Keywords: Firefox Oracle Cc: senthil.kumarn@…

Description (last modified by j.swiderski)

  1. Create a link of type url and give it an id and name.
  2. Now enter no of lines below this link. These lines are added as spacer.
  3. Create another link and select its type as 'Link to anchor in the text' and select the anchor name or id of the link created in step 1.
  4. The new link must be created quite some distance from the first link i.e the second link must be at a scrollable distace so that when we click the second link the focus moves up or down the page.
  5. Now click the second link. In IE and chrome focus will move to the first link while in firefox instead of the focus getting shifted to the target link the page reloads.

I have verified that this is not a behaviour intinsic to firefox by creating two such links in a html page without ckeditor and it behaves as expected i.e the focus shifts, just like in IE and firefox. The problem occurs only when ckeditor is loaded.

One difference I observed between the source code of the preview page as generated by IE and FF is that FF had this additional line insided the html body

<p>
	<link href="http://ckeditor.com/apps/ckeditor/3.6.3/contents.css" rel="stylesheet" type="text/css" />
</p>

If this is acknowledged as a bug we will require it to be patch in 3.3.1 and 3.5.3 also as we have customers using these releases and waiting for a fix.

Attachments (1)

9047.patch (1.5 KB) - added by fredck 3 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 3 years ago by j.swiderski

  • Description modified (diff)

comment:2 Changed 3 years ago by Rajasimhan

  • Keywords Oracle added

comment:3 Changed 3 years ago by Rajasimhan

Any updates on this bug

comment:4 Changed 3 years ago by j.swiderski

  • Keywords Firefox added
  • Status changed from new to confirmed
  • Version changed from 3.6.3 to 3.0

Problem has been reproducible in Firefox from CKEditor 3.0.

When you click on anchor in page preview - sample page you have used will be loaded.

comment:5 Changed 3 years ago by Rajasimhan

Can you provide a ETA for the fix?

comment:6 Changed 3 years ago by fredck

  • Keywords VendorFix added
  • Resolution set to wontfix
  • Status changed from confirmed to closed

This is a browser bug and I'm afraid we're not able to workaround it: https://bugzilla.mozilla.org/show_bug.cgi?id=302976

This forces us to have this limitation with the Preview button on Firefox, where anchors will not work.

A possible workaround would be using a server side solution for the preview, replacing the current implementation altogether. This can be achieved by a custom or third party plugin, like the following:
ServerPreview: Preview with a server processed page

Changed 3 years ago by fredck

comment:7 Changed 3 years ago by fredck

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Well... it looks like I was able to workaround it without a server side solution.

comment:8 Changed 3 years ago by fredck

  • Milestone set to CKEditor 3.6.4
  • Owner set to fredck
  • Status changed from reopened to review

comment:9 Changed 3 years ago by Rajasimhan

Fred, Is the attached patch compatible with 3.5.3, 3.6.2 & 3.3.1?

Thanks Raj

comment:10 Changed 3 years ago by Rajasimhan

Hi Fred, Can you comment on my earlier question?

comment:11 Changed 3 years ago by fredck

Dev site patches will always target trunk. In this case, it should work with previous versions as well.

comment:12 Changed 3 years ago by garry.yao

  • Status changed from review to review_passed

comment:13 Changed 3 years ago by fredck

  • Keywords VendorFix removed
  • Resolution set to fixed
  • Status changed from review_passed to closed

Fixed with [7527].

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy