Opened 7 years ago

Closed 4 years ago

#9050 closed Bug (fixed)

[FF] scroll to wrong position on writing

Reported by: debe Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: Firefox Cc: rick.schnorenberg@…

Description

When you set a MozTransform scale factor to the content body of the editor, when writing something the browser scroll in the wrong place. That happens too with pageDown button, the document scrolls down but not to the real end of the enlarged document, but to the end of the document without the transformation.

It seems that Firefox don't consider that zoom scale factor, that others browser do.

To reproduce this bug after the CKEDITOR.replace part add (content should be long enough to scroll):

CKEDITOR.on('instanceReady', function(ev){
            var body = ev.editor.document.getBody().$;
            body.style.MozTransformOrigin = "top left";
            body.style.MozTransform = "scale(1.5)";
            body.style.OTransformOrigin = "top left";
            body.style.OTransform = "scale(1.5)";
            body.style.TransformOrigin = "top left";
            body.style.Transform = "scale(1.5)";
            // IE
            body.style.zoom = 1.5;
        });

Attachments (1)

FF.png (51.9 KB) - added by Jakub Ś 4 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 7 years ago by Jakub Ś

Keywords: Firefox added
Status: newconfirmed
Version: 3.0

Problem can be reproduced only in Firefox from CKEditor 3.0.

comment:2 Changed 5 years ago by Rick Schnorenberg

Cc: rick.schnorenberg@… added

comment:3 Changed 4 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

I could no longer reproduce this issue in FF 41.0.1 and CKEditor 4.5.4. Please see attached image. Scrolling and paging works as expected.

NOTE: I have removed bottom content which was aligned to right because I had problems locating the cursor.

Changed 4 years ago by Jakub Ś

Attachment: FF.png added
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy