Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#91 closed Bug (fixed)

CKPackager: NullReferenceException when running under Linux/mono

Reported by: Brian Klug <brian.klug+fckeditor@…> Owned by:
Priority: Normal Milestone: FCKeditor 2.4.1
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Packager, Confirmed Cc:

Description

When I test CKPackager with the "basic" and "fckeditor" samples provided with CKPackager, it works. However, when I use it on the code currently under SVN, it outputs this error:

~/FCKeditor/2_4$ mono ~/CKPackager/CKPackager.exe editor/_packager.xml

CKPackager - Version 1.1 Build 3297
Copyright 2004-2006 Frederico Caldeira Knabben - All rights reserved
For more information please visit http://www.fckeditor.net/ckpackager

This software is not registered yet.

Please type the registration name (leave blank for demo):

You are running CKPackager in demo mode. All files generated in this mode are
bound to the terms of the CKPackager License.
Please type the word "demo" to continue and hit enter (leave blank to exit):
demo


Unhandled Exception: System.NullReferenceException: Object reference not set to an instance of an object
  at d.a (System.Xml.XmlDocument A_0) [0x00000]
  at d.a (System.String A_0) [0x00000]
  at j.a (System.String[] A_0) [0x00000]

Change History (6)

comment:1 Changed 13 years ago by Brian Klug <brian.klug+fckeditor@…>

Update:

I get the exact same error running under Windows XP with .NET.

comment:2 Changed 13 years ago by Brian Klug <brian.klug+fckeditor@…>

Update:

This is caused by

<PackageFile path=...>

vs.

<PackageFile name=...>

in the packager XML file.

comment:3 Changed 13 years ago by Frederico Caldeira Knabben

Keywords: Packager Confirmed added; CKPackager removed

Confirmed. The correct attribute name is "path" and not "name".

comment:4 Changed 13 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: newclosed

The new packager system, named FCKpackager, has been released. It is now a Open Source sub-project of FCKeditor. It can be retrieved from our SVN:
http://svn.fckeditor.net/FCKpackager/trunk

The SVN version has been already updated for compatibility with FCKpackager. The reported problem should not be an issue anymore.

comment:5 Changed 13 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.4FCKeditor 2.4.1

comment:6 Changed 13 years ago by Brian Klug

The new FCKpackager works perfectly. Thank you!

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy