Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#9165 closed Bug (invalid)

scroll bar - scrolling up automatically when user selects text from dropdownlist in Fck editor using Internet explorer

Reported by: deepisingh Owned by:
Priority: Normal Milestone:
Component: UI : Source View Version: 3.5.2
Keywords: Cc:

Description

iam using fck editor in my application....here iam facing problem with scrollbar in fck editor in Internet explorer..

i have an dropdownlist in html editor..i placed that dropdownlist at the very end in the fck editor (text area) ...if user selects any text from dropdownlist the cursor position is at right location i mean at the very end ... where as scroll bar scrolling up automatically......actually i want the scroll bar be at cursor location itself....but it is scrolling to top automatically ...pls help me out..very urgent plssss...is there anything we have to change in fckconfig.js or ckconfig.js?

Attachments (3)

FCK_Editor_Scroll_Position_Issue.JPG (44.4 KB) - added by deepisingh 7 years ago.
Fckeditor_ScrollUp.JPG (72.4 KB) - added by deepisingh 7 years ago.
The Problem is with the Scroll bar which is automatically scrolling top to FCK Editor.docx (92.7 KB) - added by deepisingh 7 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 7 years ago by Jakub Ś

Status: newpending

Sorry but I don't understand.

  1. Could you tell which are you using - FCKeditor or CKEditor? First one is not supported anymore.
  2. Could you provide step by step scenario explaining what to do to get error and whet exactly error is?

Changed 7 years ago by deepisingh

Changed 7 years ago by deepisingh

Attachment: Fckeditor_ScrollUp.JPG added

comment:2 Changed 7 years ago by deepisingh

The Problem is with the Scroll bar which is automatically scrolling to FCK Editor's starting point (Top position)after the user selects some item from the suggestion box. But Actally the scroll bar should be at the same position where user selects the item. And Cursor is also missing after the selection. But the Scroll bar is moving to the FCK Editor starting point after the selection of the item.

Please see the below demo to understant the problem clearly.

comment:3 Changed 7 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible

comment:4 Changed 7 years ago by deepisingh

i posted in fck editor relates forum ..no one gave rly to me...is there any related forums there to post in fck editor 2.x.....

see this below post i posted here

http://cksource.com/forums/viewtopic.php?f=5&t=26597

is there any online chat to chat wid fck editor people?for me it is urgent ya pls help me out....

comment:5 Changed 7 years ago by Jakub Ś

  1. FCKeditor was retired and is no longer supported. We will have v4 released soon and you are still using version 2. You should think about upgrading.
  1. You say that you lose focus whenever you select something from your custom box. Well this does not happen with FCKeditor dialogs. Perhaps you should copy this behaviour. You could try implementing your toolbox as FCKeditor dialog plugin which pops out when '[[' is entered. Another solution might be perhaps getting the selection before your custom toolbox is opened and then restoring this selection to editor when this dialog is closed.

comment:6 in reply to:  5 Changed 7 years ago by deepisingh

Replying to j.swiderski:

  1. FCKeditor was retired and is no longer supported. We will have v4 released soon and you are still using version 2. You should think about upgrading.
  1. You say that you lose focus whenever you select something from your custom box. Well this does not happen with FCKeditor dialogs. Perhaps you should copy this behaviour. You could try implementing your toolbox as FCKeditor dialog plugin which pops out when '[[' is entered. Another solution might be perhaps getting the selection before your custom toolbox is opened and then restoring this selection to editor when this dialog is closed.

comment:7 Changed 7 years ago by deepisingh

Thanks for ur prompt reply..i really thank you for the gud suggestion u made..

wht i need is scroll bar should be in the same position after i selects item from a custom selection box. currently after the selection the scroll bar is going to top position.

can u please brief where we have to modify or add our code to implement your second suggestion given below

"getting the selection before your custom toolbox is opened and then restoring this selection to editor when this dialog is closed."

can u please suggest where we can find dialog box as u described in ur first suggestion and where we have to see for the code

will definitely look into ur suggestion to get the latest version of FCK.will be thankful for your prompt reply..

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy