Opened 10 years ago

Closed 10 years ago

#918 closed Bug (worksforme)

Enter key handler causes placeholder plugin to behave strangely

Reported by: didgiman Owned by:
Priority: Normal Milestone:
Component: UI : Enter Key Version: FCKeditor 2.4.3
Keywords: Pending WorksForMe Cc:

Description

The introduction of the new enter key handler causes the placeholder plugin to behave in a strange way, that I'm not certain is caused by the plugin.
This bug can be seen in the included samples: javascript - sample 6 - plugin support.

To reproduce:

  • Place your cursor in the editor area
  • Click the "placeholder plugin" button
  • Enter text for the new placeholder
  • Press ok to insert the placeholder
  • When focus returns to the editor area, you'll see that the new placeholder is added
  • Press enter
  • You'll see that a -very small, but visible- new placeholder is created on the next line by the editor. It is selected and has the corner handles
  • Type some text
  • Go to source view
  • Return to WYSIWYG view
  • A second plugin, identical to the one you created before is automatically displayed

Change History (2)

comment:1 Changed 10 years ago by Wojciech Olchawa

Keywords: Pending WorksForMe added; enter key placeholder plugin removed

Hi!

I couldn't reproduce your problem, neither on IE and IE7 nor on the FF2. Could you please specify what kind of browser are using. Could you please right does the same thing happens in the newest version 2.5.1?

Thanks!

comment:2 Changed 10 years ago by Wojciech Olchawa

Resolution: worksforme
Status: newclosed

Ticket expired.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy