Opened 7 years ago

Closed 5 years ago

#9201 closed New Feature (wontfix)

When CKEditor is inside an IFrame, it is not possible to move dialogs outside the IFrame

Reported by: Teresa Monahan Owned by:
Priority: Normal Milestone:
Component: UI : Dialogs Version: 3.6.4
Keywords: IBM CantFix Cc: Damian, Satya Minnekanti

Description

To see an example of this:

  • Save the attached 2 files into the _samples directory.
  • Open editorInIFrame.html in a browser.
  • Open the Find dialog.
  • Try to drag the dialog outside of the IFrame.

Problem: It is not possible to move the dialog outside of the IFrame. This makes it difficult to use the Find/Replace features since the dialog obstructs much of the editor.

The reason we would like support for this is to use CKEditor with Open Social APIs. This requires CKEditor to work as a gadget in an Open Social container (e.g Shindig) where the CKEditor dialogs can open in a specified target frame/IFrame instead of in the HTML page of the editor.

One idea we have discussed as a possible workaround for this was to hide another editor instance in the frame/IFrame where we want the dialog to display and switch the editor documents between the 2 editor instances. However this is not ideal since it requires an extra editor instance and there could be many other undesired consequences of this.

Since Open Social is becoming widespread in enterprise applications, it would be great for CKEditor to support this usecase. Is there some other way this can be supported?

Attachments (2)

frame1.html (1.0 KB) - added by Teresa Monahan 7 years ago.
editorInIFrame.html (687 bytes) - added by Teresa Monahan 7 years ago.

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by Teresa Monahan

Attachment: frame1.html added

Changed 7 years ago by Teresa Monahan

Attachment: editorInIFrame.html added

comment:1 Changed 7 years ago by Teresa Monahan

Type: BugNew Feature

comment:2 Changed 7 years ago by Frederico Caldeira Knabben

Component: GeneralUI : Dialogs
Status: newconfirmed

There is no current way to support it.

comment:3 Changed 7 years ago by Damian

Can this be added to v4?

comment:4 Changed 5 years ago by Christophe Guillou

We are ok to get this one close - since I dont think this is technically achievable.

comment:5 Changed 5 years ago by Frederico Caldeira Knabben

Keywords: CantFix added
Resolution: wontfix
Status: confirmedclosed

I appreciate the feedback and your position about it. I couldn't agree more.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy