Opened 7 years ago

Closed 7 years ago

#9204 closed Bug (invalid)

Adding a link to an image removes the ability to edit that image attributes

Reported by: Marcher Owned by:
Priority: Normal Milestone:
Component: UI : Dialogs Version:
Keywords: Cc:

Description

Descriptive summary: Upon adding a link to an image's attributes and saving the dialogue, upon attempting to adjust the image attributes, one is instead editing the link attributes. Steps to reproduce: http://ckeditor.com/demo double click the image, go to the link tab, add a url, save the dialogue, re-open and note it is the link dialogue. Browser name and OS : FireFox 14.0.1 for Ubuntu Canonical 1.0, Ubuntu 12.04 Precise Screenshots: http://i.imgur.com/fq5EJ.png http://i.imgur.com/vNnpk.png Sample data

<a href="http://a.cksource.com/c/1/inc/img/demo-little-red.jpg"><img alt="" src="http://a.cksource.com/c/1/inc/img/demo-little-red.jpg" style="margin-left: 10px; margin-right: 10px; float: left; width: 120px; height: 168px;" /></a>

Change History (2)

comment:1 Changed 7 years ago by Marcher

desired/expected behaviour: edit image attributes as normal, link tab holds image link url.

comment:2 Changed 7 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 3.6.4

That is because Edit Link becomes default operation for double-clicking.

To open Image properties you have to right-click and choose Image properties option or click on image and next click on image button in toolbar.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy