Opened 7 years ago

Closed 7 years ago

#9225 closed Bug (fixed)

Find is always doing a cyclic search even if 'Match cyclic' is not selected

Reported by: Teresa Monahan Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.0
Component: General Version: 4.0 Beta
Keywords: IBM Cc: Damian, Satya Minnekanti

Description

To Reproduce:

  • Open any CKEditor sample and enter some sample text e.g. 'this is a test'.
  • Place the cursor at the end of this text and open the Find dialog.
  • Type in a word that does appear in the editor e.g. 'test'
  • Uncheck 'Match cyclic' and click Find.

Problem: The text is found even though the word appears before the cursor.

Expected result: The text should not be highlighted and 'The specified text was not found' message should be displayed.

Change History (6)

comment:1 Changed 7 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.0
Status: newconfirmed

comment:2 Changed 7 years ago by Piotrek Koszuliński

comment:3 Changed 7 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedassigned

comment:4 Changed 7 years ago by Piotrek Koszuliński

Status: assignedreview

Pushed t/9225.

Reverted part of https://github.com/ckeditor/ckeditor-dev/commit/4040e4f. I don't know what was it for and I haven't found any obvious issue breaking find dialog in both inlineall and divarea samples.

Garry, do you remember purpose of that patch?

comment:5 Changed 7 years ago by Garry Yao

Status: reviewreview_passed

That line looks like a mistake indeed, but note that the reason for such change still remains:

editor::getSelection would not return null when editor is not focused as in v3, it returns now a selection with type NONE, this's to enable making a selection even when editor is not focused.

But in this case find dialog will always pre-focus the editor, so such guard is not required.

comment:6 Changed 7 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy