Opened 7 years ago

Closed 7 years ago

#9244 closed Bug (fixed)

Certain content overflow inline editable

Reported by: Garry Yao Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 4.0
Component: General Version: 4.0
Keywords: Cc:

Description

The <pre> content would possibly overflow any inline editable, or enlarge it.

  1. Load inlineall sample;
  2. apply the "Formatted" style to some paragraphs
  • Actual: the editable element is enlarged/penetrated.

The table insertion (which imposed a fixed width) also has a similar problem.

Change History (5)

comment:1 Changed 7 years ago by Piotrek Koszuliński

Status: newconfirmed

comment:2 Changed 7 years ago by Olek Nowodziński

We cannot do anything except apply overflow:hidden/scroll to the editable. This is sweeping things under the carpet though and it just might bring more confusion to the problem. I guess that we cannot bypass this issue since it's a natural consequence of the inline editing.

comment:3 Changed 7 years ago by Garry Yao

Owner: set to Garry Yao
Status: confirmedreview

Well, it's a matter of providing a better line-wrap/word-wrap style to the sample page, and I agree that we can consider it as NOT a bug.

comment:4 Changed 7 years ago by Garry Yao

Opened t/9244 for sample style changes.

comment:5 Changed 7 years ago by Olek Nowodziński

Resolution: fixed
Status: reviewclosed

What Garry has proposed is far enough for us. After all, I think that we shouldn't fix overflow issues for inline editing:

  1. We can't do this perfectly. For example: still when inserting a 500px table it floats outside of the editable.
  2. This may confuse people. If someone wants to have a perfect, non-overflowing and non-intrusive editing, this is exactly what framed WYSIWYG and divarea are for. Otherwise (if we prepared tons of similar hacks) users would expect our inline editing to be always working this way, which is a serious misconception as content overflowing is a natural consequence of how HTML works.

Masterized t/9244.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy