Opened 7 years ago

Closed 7 years ago

#9249 closed Bug (fixed)

Escape key does not close the a11yhelp dialog

Reported by: Teresa Monahan Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 4.0
Component: General Version: 4.0
Keywords: IBM Cc: Damian, Satya Minnekanti

Description

To Reproduce:

  • Open the a11yhelp dialog using the Alt+0 keystroke.
  • Press the Esc key to close the dialog.

Problem: The dialog does not close. All other dialogs do close correctly when the Esc key is pressed.

Change History (3)

comment:1 Changed 7 years ago by Garry Yao

Owner: set to Garry Yao
Status: newreview

Caused by: https://github.com/ckeditor/ckeditor-dev/commit/47f8446b766444c55d2cb307264671b64132914d

We should instead fix the incorrect focus usage on html type field, since html field should only gain focus on requested.

comment:2 Changed 7 years ago by Piotrek Koszuliński

Status: reviewreview_passed

I rebased t/9249 + fixed indentation.

comment:3 Changed 7 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy