Opened 12 years ago

Closed 12 years ago

#927 closed Bug (worksforme)

Ctrl-X not working in Opera for the first selection

Reported by: Martin Kou Owned by:
Priority: Normal Milestone: Opera Compatibility
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Opera Cc:

Description (last modified by Martin Kou)

Summary:
After FCKeditor is loaded, the first selection cannot be cut by Ctrl-X.

Reproduction procedures:

  1. Grab the newest FCKeditor code or the 2.4.3 code from SVN.
  2. Load one of the samples in Opera 9.21.
  3. Select some text.
  4. Press Ctrl-X.
  5. The text is not cut.

Change History (5)

comment:1 Changed 12 years ago by Martin Kou

Description: modified (diff)

comment:2 Changed 12 years ago by Martin Kou

Commenting out the FCK.KeystrokeHandler.AttachToElement(...) lines in fck.js would not prevent the bug from happening. So it shouldn't have to do with the keystroke handler logic. And I'm quite certain that it has nothing to do with event.preventDefault().

comment:3 Changed 12 years ago by Aleksey Onopriyenko

Ctrl-X works properly if text is selected using keyboard (Opera 9.23). I guess this bug is related to #1107.

comment:4 Changed 12 years ago by Hallvord R. M. Steen (Opera Software)

Works for me I think

comment:5 Changed 12 years ago by Frederico Caldeira Knabben

Resolution: worksforme
Status: newclosed

Works for me too, with the trunk and Opera 9.50 Alpha (9491). Feel free to reopen it if you have different results Martin.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy