Opened 7 years ago

Closed 7 years ago

#9302 closed Bug (invalid)

Is there a way we can prevent FCK editor not to HTML encode following symbols <,> and &

Reported by: Hari Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: FCKeditor 2.3.3
Keywords: Cc:

Description

We need to prevent FCK Editor not do following things Don't do HTML Encoding. Don't massage the HTML tags for eg: if we add </div> it should not additionally add <div> to it.

Our main concerns is we don't need the editor to massage the data.

Please let us know how we can achieve this

Change History (1)

comment:1 Changed 7 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
  1. FCKeditor is no longer supported. We have just released CKEditor 4 beta - http://nightly-v4.ckeditor.com/ (you might want to consider upgrading)
  1. Don't massage the HTML tags for eg: if we add </div> it should not additionally add <div> to it.

This is by design and can't be turned off. Editor would become maintenance nightmare if we allowed for such things. There would be lots of weird bugs. I don't think any editor allows for this.

  1. encode following symbols <,> and &

http://docs.cksource.com/ckeditor_api/symbols/CKEDITOR.config.html#.forceSimpleAmpersand http://docs.cksource.com/ckeditor_api/symbols/CKEDITOR.config.html#.basicEntities Please note that if you plan to use HTML this should not be changed. You should rather fix errors in your webapp.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy